Controller randomly stops working when headset plugged in.

I recently purchased a turtle beach XO 7 headset and downloaded the update for the controller as well.  At random times the controller will stop working and I'll have to remove the batteries then place them back into the controller to get them working again.  I've tried on multiple controllers and the same thing happens on them as well.  I've tried different batteries and such also.  Not sure if anybody else is having this issue or not but it is a pain the in *** especially when it seems to be happening every 5-15 minutes at random times.

 

Question Info


Last updated July 4, 2018 Views 0 Applies to:

I had the same issue,I talked with MS support chat, he told me to put my console on energy saving mode.Then go into Network, Advanced settings, Alternate Mac address, Then Clear.The Xbox will restart, Don't ask me why or how but this seems to have worked for me! I've been playing for hours with the XO7's without a single controller freeze.He also recommended I hold down the power button until the Xbox shuts down then unplug it from the wall and any connections for at least 1 hour.So far so good I hope it works for others as well.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'll give it a shot tonight and see if it works... Hopefully they release an update so this isn't necessary lol.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

yup this happens to me at random......also audio is distorting at random to! what on earth is wrong with this thing!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I bought the XO7 headset yesterday after work.  Played all night with no issues.  Suddenly today, I'm having the exact issue described by the OP.  Controller disconnection message (even though the light on the controller remains on), have to pull the batteries and re-insert them.  It happened 3 times in roughly an hour.  Getting a little frustrated.  

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I suggest to chat with MS support the more of us that do the more likely they look into this problem.Doing what I said in my other post made a difference for me I played for over 8 hours without a disconnect and I was getting it every half hour give or take before that.I contacted MS support chat when it happened again they are now advising I use the Offline System Update Diagnostic Tool because they think it's definitely to do with the software update.I'll let you all know how this goes after I've tested it.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey joeyfitzroy did you get any results?  I did the clear of the alternate MAC address and it fixed the problem for roughly 24 hours, now it is back to disconnecting every 20 minutes or so.  

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Unfortunately not. The offline system update did not fix the problem. MS support have now asked me to send in my controller to be replaced, glad I have a back up controller that doesn't have this issue or I'd be really peeved.  

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.