Controller Issues... any help appreciated!

Hello, I recently bought a used Xbox 360 controller on ebay. It is in great condition, but it has issues that the seller stated before I bought it. The price was too good to pass up, and I'm hopeful for an easy fix. When I first got the controller, I put in my rechargeable battery pack, pressed the guide button, and the lights came on as usual. The lights stayed on until I hit the sync button on my controller (and console), then the light came on like it would for "player 1", and went off quickly. Now every time I hit the guide button to power the controller on, the lights come on until it lights up for "player 1", and then the lights go out quickly and the controller goes off. The previous owner had the controller do the same thing while using AA batteries, and I've had it do this while using a rechargeable battery pack, and my plug and play cord as well. I also turned my other controller on first, and then turned on this controller as "player 2", but it did the same thing... lights on, then off quickly, and controller shut down. The previous owner says he bought the controller new, and he also says he never modified it in any way. He said he used it for about a week, and then it began doing this. Any help is appreciated. - Thanks 

 

Discussion Info


Last updated July 4, 2018 Views 2 Applies to:

IS it an aftermarket controller?   In the recent update MS made it so the system automatically shuts them down and won't let you connect.   The only way to keep the controller on is to have the console off, which of course makes it useless.   It's not all aftermarket controllers though.

-

So basically, is it an Official controller?   And if not who makes it?

Edit ran out.

Found out it's Datel controllers.   I linked a thread about it from right after the update below.   Hopefully, you don't have one but that's the only instance I've heard this happening.

forums.xbox.com/.../1434144.aspx

It's an official Microsoft controller. The Halo 3 green controller to be exact.

Well then it could be a loose connection to the battery back, trying holding it in place a while and see if this helps.   Or some other defect like a bad board.   These are the two most common answers I found for being the reason.   But, unfortunately I don't have a real answer for you.

-

Although I question, if the controller was really only about a week old why the original owner didn't just exchange it....

I don't understand that either. I don't know where he bought it. I've already been looking on ebay for a new board, if I could get one cheap enough, it would be worth it. The controller is in really nice shape.

Did you check the battery pack and how well it sits for connection reasons?   Even so I'd try turning it on while holding it firmly in place, just in case, worth a shot at least.

I tried it, same result though.

Hmmm, then it must be the board or some other internal part that's broken/defective.   Nothing else I can think of at least.

I think it's an internal problem as well. I might just sell it on ebay, and look for another for myself.