Controller doesn't work with batteries.

One of my controllers only works using a play and charge kit, if I try and use batteries then it disconnects every  minute or two. I have checked the batteries in a different controller and the controller works fine.

I was wondering if anyone had any suggestions on fixing this?

Thanks

 

Question Info


Last updated July 4, 2018 Views 0 Applies to:

Hi, are the connections in the controller dirty maybe, try giving them a gentle wipe. Do the batteries fit securely, you could try very gently prying the connectors upwards a little but please be very gentle doing this so you don't snap the connectors off.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

What happens when you put the batteries in? If you turn the contoller on and give it a gentle shake does the control turn off? Sometimes the brand of battery you use can cause some issues. I know that there are certain brands where the battery is in fact a bit smaller than normal ones. This can cause problems with it having a connection problem.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Greetings, Etheral Daemon! It looks like ThingOnAString successfully answered your question. Happy gaming to you!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.