Constantly disconnecting from games, not Xbox Live. (BF3)

I mostly play Battlefield 3. As of today (about an hour ago when I first got on today), I will join a game and be okay anywhere from 30 seconds to 3 minutes then get booted. Once I'm back to the Bf3 main screen, it pops up and tells me I lost connection to the session. I've followed pretty much everything in the support section to fix disconnects: rebooting network hardware, wired connection (was wired the whole time), connecting straight to modem (by passing router), have a friend try these solutions (sadly, all my friends are online playing without me :-/). Idk what to do. Every time it happens, I stay in the party I'm in. I an still talk to my friends. It just boots me from the game. I've tried playing on different servers and playing on different servers without my friends with no better result.

Help! Please!

 

Question Info


Last updated July 4, 2018 Views 10 Applies to:

Greetings EnginerdDave!

You seem to have taken the proper steps to troubleshoot your network equipment. However, there is one thing i would like to know and that is the make and model of your modem.

Have you tried with a different Ethernet cable? If the one you use is faulty.

Let's try a few troubleshooting steps on your console.

Start clearing your Xbox system cache. This will remove temporary files from the system cache. Here's how!

Delete your profile. It is important that you select Delete Profile Only. This deletes the profile but leaves saved games and achievements. 

  1. Go to Settings, and then select System.
  2. Select Storage.
  3. Select All Devices.
  4. Select Gamer Profiles.
  5. Select the gamertag that you want to delete.
  6. Select Delete.

Restore your Xbox network settings to factory defaults.

Do you have BF3 installed on your Xbox hard drive? Make sure there are no corrupted files associated with BF3 game. Corrupted contents is shown as an yellow exclamation mark.

Post back and let us know how it goes. 

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Modem is a Cisco DPC3000. Router is a Linksys WRT610N.

I have tried swapping Ethernet cables. I cleared my cache twice. Took out my HDD and re-seated it. I redownloaded my profile. I deleted the Bf3 install and ran it just with the disc, and same error. I could not find any corrupt files in any game folders ( I don't have many ). I added my xbox's DHCP ip address to the DMZ of my router. I can ping epix.xbox.com.

EA server status all say up for Bf3.

Unless you guys have any other ideas, I think I may be down to deleting all the updates/expansion packs and redownloading them. But that is several gigs of stuff and I was trying to use it as a last resort. :-/

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Having the same problem as you, Dave.. Looks like several others are tonight as well:  answers.ea.com/.../false

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

@Staindaero

Well at least I'm not alone. But the guy at the bottom saying he deleted the title update and it worked for him, yeah well did that a couple times and no luck. I just got off the phone with Xbox Live support after 2 hours, that didn't fix it either. I'm deleting Bf3 from my console and starting from scratch again. That's all there is left to do, that I see.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yeah, Dave.. I tried that suggestion as well.  Please report here if you find a solution - I will be sure to do the same!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks, friend. WIll do.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

i am having the same problem.for me its been on and off for a few weeks now.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The Battlefield server status page only shows you the status of the game servers, however EA could have been experiencing Origin Account issues at the time.

I suggest you head to http://help.ea.com and raise a ticket with them and they should be able to check whether your account is experiencing any issues. Could also be ISP routing issues between your ISP and EA's Master Servers at the time you were playing.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.