Constant Xbox live disconnects recently started

So for the past few months I have been riding the networking issue roller coaster, and have been able to identify and fix a variety of issues. But now I have come to the point where I no longer know what to do and can't find any information on my current issue at hand. So, for context purposes, I will go over how this issue arose. Before I was being bombarded by caterpillars, I was having a weasel or baboon error every 3-5 mins I tried to play anything multiplayer especially in the later evening to nighttime hours.. From stuff as little as random match-made crucible matches to six man Crota and VoG teams. Whenever I did anything solo PvE such as solo Nightfall/Raid/PoE/Patrol I rarely got any error codes (though they would still happen). This problem turned out to be that our modem and router were VERY outdated. So we went to our ISP to upgrade and we got a new Gateway (router modem combo) because that was cheaper than getting a separate modem and router. The moment we installed the new Gateway ( a Netgear AC1900 C6300BD) my baboon and weasel errors instantly vanished. And for a day everything seemed fixed, but as soon as I started playing solo PvE for any real length of time, I noticed that this new problem had appeared. It only happens when playing solo ( no fire team ) crucible or PvE and tends to happen more during afternoon/midday. If I am in a fire team this issue will not occur, but if I am alone I will get constant Caterpillar errors or Xbox live disconnects with an interval of 3-5 mins. One trigger I have noticed for these errors is trying to load a patrol or story mission too fast (speed running daily heroics or bounties). In between areas I will hit loading zones, which in themselves aren't to weird. The strange thing is when the loading zone sets me free before the area is loaded and I will sparrow out into empty space and quickly get booted from Xbox live. After getting disconnected, I can usually reconnect quite quickly. There are occasions though where to be able to sign in I have to test my connection before it will let me sign in. These tests never show any type of problems though.

I have heard from some sources that gateways usually don't have the best routers so, I plugged up the one we had used before (which didn't trigger this particular issue), and nothing changed, so that is not my problem. As to my internet I have a Ping of 39ms, Download of 59.39Mbps and Upload of 17.20Mbps.

I have tried to either deal with or fix this problem for a few weeks now and it is really started to get on my nerves. ANY help on how to fix this issue would be VERY much appreciated, Thanks!

 

Question Info


Last updated July 4, 2018 Views 4 Applies to: