Constant Disconnect and Slow Speeds

Router : Huwaei Echolife 520b

ISP:TalkTalk

Speed Test:http: 

Xbox Adapter: G (Single Ariel, Grey Box)

NAT: Open

UPNP: Enabled 

Problem: (This is all refering to Black Ops but the problem is the same in all Games)

  1. My Xbox will randomly disconnect , The longest gameplay i get is around an Hour but usually only lasts for half that. 
  2. Connecting to begin with is hard i usually have to wait 10 minutes before i can connect. Even then i usually wont sign in to messenger and it takes lots of attempts.
  3. Playing player matches are always laggy, It often finds lots of matches but it goes through loads before i can connect to one.If i do this it will tend to come up with connection error half way through anyway. It usually takes a while to load the Black op severs and 50% of the time a message appears saying the Black op severs are unavailable
  4. Generally if i can connect which 75% of the time i cant... it is really slow.
  5. Oh and i moved my xbox right next to the router to see it the distance was the problem... its not
  6. I Know my adapter is fine because before i had it, it was my friends and worked normally. My Xbox is fairly old though, could that have an effect?

 

 

Question Info


Last updated July 4, 2018 Views 3 Applies to:

Hi,

 

TalkTalk had very similar issues around 2 months ago, maybe their problem has returned. Have you tried wired as a test to see if its just wireless that is a problem

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have had this problem for a while now, wired connection always works, but wireless does not. I rang up TalkTalk earlier they said everything was fine and i should try port forwarding.. well I have done that and nothing changed.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Well if wired works ok forwarding won't help just for wireless, its just their standard response

 

I would look at experimenting with your wireless router channel, some work better than others.

 

If your not using wireless channel 11 already try that, if your using 11 try the tips here  http://www.unofficialguidetolive.co.uk/faqs/114-troubleshooting-and-improving-wireless including using Xiruss or inSSIDer to find out what other wireless networks are in use in your area and choosing a channel that isn't close to other networks

 

 

 

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Ok, i did this to no effect

I have also found another symptom....

When my xbox disconnects so does my laptop... and for a couple of minutes it cant reconnect. plus it seems to mainly happen when i have both on at the same time... bassically is there any reason why a router would loose its signal for a couple of minutes, especially when its usage is increased?

... do u just think its about time i got a new router?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

 

It sounds like your router must be having issues, if yours is the type of router that has removable aerials ensure they are nice and tightly fixed to the router, if possible try moving the router to a more elevated position and away from obstructions. Also see if there is a more recent firmware update available for your router to try out.

 

Are both the laptop and Xbox using an automatically assigned IP address ?

 

There is no real reason for wireless to drop out like that unless its a fault with the router or a bug in firmware, its certainly not normal.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yeah Thats what ive been thinking.

The firmware is up to date and it doesn't have aerials. Im guessing i am going to have to get a new router but im going to try factory reset see if that does anything... I will elevate it but i doubt that will have an effect.

As you seem in the know how, what router would you recommend for gaming?

Oh and Yes both Xbox and Laptop are automatically assigned. I rang up talktalk asking for my name sever/DNS to set up a static ip but they said they dont do that or something and i couldnt do it... do you think thats the issue?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

No that won't help it mate, it just sounds like all of your wireless drops out and restarts.

 

As TalkTalk supply their own routers I would report it as fault and explain that wireless side of the router keeps cutting out, ask them if they can supply one of their Dlink or Netgear routers as a replacement. Its worth a shot before buying one yourself.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Ok cheers, but i have a feeling they may still charge for replacement anyway, but will give it a shot :0 Thanks for all our help

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

If they are going to charge just pick yourself up a cheap Dlink DSL2640B on eBay if you can, great router and you can get them for cheap on there as there's a newer model out now the 2640R.

 

I still use the 2640B is a belting routing

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.