Connection to Xbox Live

So here is my repost with the necessary info. As I've said before I cannot connect to Live at all after a few days of getting dropped after 5-10 minutes.

USA / Illinois

RCA by Thomson DCM425 modem

Netgear wireless N 300 router

wireless connection

WPA2

black external adaptor

UPnP - unknown

NAT - open

Cable

Mediacom

Can't connect to your wireless network. Your wireless network is secured with a WEP or WPA passphrase. Your console may be using the wrong one.

Can't connect to your wireless network. Turn your router or modem off and back on, then wait 30 seconds.

 

Question Info


Last updated July 4, 2018 Views 9 Applies to:

Hey there - are you sure your console is using the correct WPA2 passphrase? If so, can you try changing the passphrase on your router to something different, and see if that helps?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Ok, did that and now I get the following message after attempting a test:

Your console can connect to Xbox Live, but your router or gateway isn't properly responding to ICMP responses...And right before I hit reply I tried the test again and got connected. Odd that...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Interesting- so, your console is connected now without issues? Or are you still getting the ICMP issue?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.