Connection test says everythings fine, but it's not.

Recently I've been having trouble staying connected to xbox live. I have a slim connected to a pretty crappy wireless router. I'll stay connected for about 15 minutes to an hour, loose connection, run the connection test, and the test connects to xbox live just fine.  I really wanna fix this, because disconnecting from xbox live in the middle of multiplayer matches over and over isn't fun. 


The error status report is this: 

W: 0000-0021
X: 0000-000D
Y: 20A8-4800 
Z: 0000-0000
ID: FFFF-FFFF

 

Question Info


Last updated July 4, 2018 Views 1 Applies to:

Hey mate, could you please take a few minutes to answer the questions in bold here? The more info we have, the better support we'll be able to provide. Thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

What Country/State/Province do you live in? Utah, USA

Modem brand & model number:  Cisco 2100

Router brand & model number: Belkin F5D7234-4 V5

Network Connection Type: Wireless

If Wireless, what type of encryption are you using? WEP

If Wireless, are you using a white or black external adapter, or an internal (Xbox 360S) adapter? Internal

Things you have tried:

Is UPnP Enabled? Unknown

Is NAT Type Open? Yes

Any Error Codes you encounter: None

What type of internet do you have? Cable

Who is your ISP(Internet Service Provider)? Xfinity/Comcast (whatever it is)

After you run "Test Xbox LIVE connection" and click on "More info", what is the exact message shown on screen?

None, just when I hit "Y" for the status it gives me that error message

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi have you tried changing your wireless channel?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.