Connection Problems: Lag

I've been having problems with lag and general poor connections with online gaming.  Particularly with MW 3, Black Ops 2, and now Crysis 3 (Crysis 2 was also bad).  It is frustrating.  

I've tried everything from port forwarding, QOS, DMZ, etc. but continue to have problems.  Thought I would post here in hope of finding some help.  Thank you in advance.

My info is below:

What Country/State/Province do you live in? United States/Philadelphia, PA
Modem brand & model number:  Motorola Surfboard SB6121
Router brand & model number: Linksys WRT54GL
If Wireless, are you using a white or black external adapter, or an internal (Xbox 360S) adapter? wired
Things you have tried: 
Is UPnP Enabled? Yes
Do you have a NAT error? NO If so, what is your NAT? Open
Any Error Codes you encounter: N/A
Who is your ISP(Internet Service Provider)? Comcast
After you run "Test Xbox LIVE connection" press “Y” for "More Info”. In the pop-up that appears, what are the following values, if shown? (If a value below does not appear for you, just leave it blank.)
W: 0000 - 000B
X: 0000 - 000D
Y: 20A8 - 4800
Z: 0000 - 0000
ID: FFFF - FFFF
L: 0015 - 10F0
Q: 8007 - 0435
T: Wired
D: 8.8.8.8/8.8.4.4 

 

Question Info


Last updated July 4, 2018 Views 8 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

As a test have you tried connecting directly to the modem and set your Xbox network settings to auto (you will have to restart the modem after you connect it to the Xbox)

Give that a go and see what happens, also run www.speedtest.net and www.pingtest.net on a PC and post the results of the tests

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

[View:http://www.pingtest.net/result/77503505.png] - Java installed and Pingtest run.

I Appreciate everyone's help. Thank you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

OK, I tried a straight wired from modem to xbox.  Crysis 3 worked okay.  No noticeable difference.  Black Ops 2 was actually worse than it has ever been.  I don't understand that. That game is a mess.

Then I tried the ping test while playing:  It occasionally timed out the jumped up to 1000+ MS and back down.  It was averaging high 20s to mid- 30s. though.  I have no idea what any of these means nor its significance.  Here is a sample:

Request timeout for icmp_seq 347

64 bytes from 173.194.73.147: icmp_seq=347 ttl=47 time=1004.528 ms

64 bytes from 173.194.73.147: icmp_seq=348 ttl=47 time=46.945 ms

64 bytes from 173.194.73.147: icmp_seq=349 ttl=47 time=156.224 ms

64 bytes from 173.194.73.147: icmp_seq=350 ttl=47 time=121.899 ms

64 bytes from 173.194.73.147: icmp_seq=351 ttl=47 time=55.732 ms

64 bytes from 173.194.73.147: icmp_seq=352 ttl=47 time=119.364 ms

64 bytes from 173.194.73.147: icmp_seq=353 ttl=47 time=29.060 ms

64 bytes from 173.194.73.147: icmp_seq=354 ttl=47 time=28.287 ms

64 bytes from 173.194.73.147: icmp_seq=355 ttl=47 time=27.702 ms

64 bytes from 173.194.73.147: icmp_seq=356 ttl=47 time=31.193 ms

64 bytes from 173.194.73.147: icmp_seq=357 ttl=47 time=29.288 ms

64 bytes from 173.194.73.147: icmp_seq=358 ttl=47 time=32.696 ms

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I contacted Comcast and they reset my modem so we will see what that does.  They had no explanation for the ping problems and the time outs I kept getting.  They wanted me to check my speed at speedtest.net!  Hopefully the connection will prove more stable.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

[quote user="Foedus Gratiae"]

... Then I tried the ping test while playing:  It occasionally timed out the jumped up to 1000+ MS and back down....

[/quote]

Then this seems like an issue with your Internet provider. If the connection to Google goes down or even times out, then there is a high probability that your Internet connection got disturbed somewhere "outside" of your house (at least a higher probability than Google going "down"). Meaning, it's your ISP's responsibility to get you a more stable connection.

Troubleshooting this issue can't be done by you. But either the cable to your house is "flaky", or the CMTS in your region is overbooked, and if a lot of people start going online after work or on weekends, the CMTS is "overladen" with traffic, and drops connections temporarily.

Additionally, sometimes ISPs try to detect if the user is contacting a Speedtest server (i.e. they cheat). You will then get a higher priorization of your traffic, so the measurement "looks awesome", and as soon as the test is through, you are put back on a bumpy trail instead of the information superhighway.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

If you have a Router behind a Cablemodem it could be that you have to enable WAN PING. I enabled this and most lags are gone for me.

Here are a description how it works for Linksys Routers. If you enable it. Restart your Router and tell back if it help or not.

www.ehow.com/how_8504133_enable-wan-ping-linksys-router.html

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

[quote user="Foedus Gratiae"]I've been having problems with lag and general poor connections with online gaming.[/quote]

First of all, please bear in mind, that whenever you experience lag in a multiplayer match, your connection is not necessarily to blame.

If you are matched with players from a different continent, or players with a slow internet connection, it doesn't matter how good your connection is. If the other player can't send updates to your console fast enough, the gameplay will lag for you.

With that in mind, please provide a bit more information about your connection.

Specifically, go to http://www.speedtest.net and post the results here.

Then before you start a multiplayer match, start a command prompt on your PC (on Windows simply press "Windowskey + R" and type "cmd" in the small window. On a Mac or Linux PC, open up a Terminal)

In that black window you type:

ping www.google.com -t

(If you use a Mac or Linux, omit the "-t")

Now play a multiplayer match.

Do the numbers significantly change, when you play and experience lag?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hope it works out for you Foedus. Let us know if you need any more help! :D

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Rabid Tar Heel, these forums work best when you create a new thread with a first post of your own, as the original poster's problem and solution, although similar, could be very different in detail. It's great that you're researching here, but the quickest path to a solution is your own new thread.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Wow, ive been having the exact same problem, i live in NC have Windstream DSL, ivne everything u can suggest to correct the problem, my ISP sent someone out today and put in a new router, guess what, no difference and they are clueless as to why this is, they even asked me if there had been a recent update to xboxlive that may have madw a change in the live servers, i wouldnt know that, but the funny thing is I NEVER had ANY problem until i started playing black ops 2. Coincidence?? Maybe, but BF3, Halo 4, RDR, u name it, all worked fine. I dont know whats going on, but i hope it gets resolved soon as i will not continue to pay for a service i cant use.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.