Connecting to Xbox Live From Behind a Sonicwall

Hi Guys,

I have just acquired a SonicWall.  As you may expect this isn’t playing very well with Xbox Live.

It connects and seems to be working fine until it randomly disconnects.

 I have forwarded all the ports that were suggested to forward, and more, and it still does not work. I have also tried putting the Xbox in the DMZ zone, which did not help either.

 

List of Ports Forwarded.   UDP: 88,3074,53,7777,3776,1900, 1863

TCP: 3074, 53, 3390, 3932, 1863

I have also looked in the logs of the SonicWall and seen events like this: 

09/29/2013 18:51:10.528 Notice Network Access UDP packet dropped 65.55.42.183, 3074, X1 my.ip.address, 8278, X1 UDP Port:  8278

They are coming from Xbox Services, Port 3074, and From a Microsoft Registered IP, but they port on the destination keeps changing. These events happen as the disconnect occur.

Short of putting an allow all from WAN > LAN and pointing it towards the Xbox, which I don't really want to do, I'm out of ideas.

If it helps I am using a SonicWall TZ100 Wireless-N, Running Firmware SonicOS Enhanced 5.8.1.13-1o

Any Suggestions will be greatly appreciated.

 

Question Info


Last updated July 4, 2018 Views 583 Applies to:

Hi Paul,

Man sorry to hear about the connection troubles. Let's see if we can get this working.

I assume you have already seen this, but I would suggest taking a peek at this port forwarding article. Not the exact model of your router, but it should be pretty much the same ports.  

To get a better idea of your network setup, please go ahead and reply to the bold info below. 

After you run "Test Xbox LIVE connection" press “Y” for "More Info”. In the pop-up that appears, what are the following values, if shown? (If a value below does not appear for you, just leave it blank.)
W:
X:
Y:
Z:
ID:
L:
Q:
T:
D:
S:
C:
 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for your quick reply :)

W:0000-000B

X:0000-F001

Y:20A8-48E0

Z:0000-0000

ID:0007-0000

L:0015-10F0

Q:8007-4035

T:Wired

D:192.168.7.202/255.255.255.0

S:192.168.7.1

C: 8.8.8.8/8.8.4.4

Forgot to put that TCP Port 80 is forwarded too.

Thanks

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Greetings Paul!

Could you post the make and model of your network equipment, such as a modem and or router.

May I ask why you have acquired a SonicWall for your network. 

Run a diagnostic test to Xbox LIVE and let us know the outcome from this test and if you receive any error related to your NAT. Navigate to Xbox network settings and select Configure Network. Select Test Xbox LIVE Connection.

Thank you! 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It is a NAT issue, as the Sonicwall - Model Posted Above - TZ100 Wireless N, does not have UPNP.

I have put it on the network as I have recently got a job that uses these and wanted to familiarize myself with them.  They are designed for security and work networks, therefore having trouble with Xbox Live.

I believe that I have sorted the issue though.  Testing as we speak. I have allowed the IP range that I believe is used by Xbox Live, 65.55.42.1 - 65.55.42.254 and pushed it towards the Xbox. Can either of you guys confirm the IP Range of the Xbox live servers?

Thanks

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The main problem is if you have multiple layers of NAT.

What is the make and model of your gateway?

Have you tried the SonicWall knowledge base: https://www.sonicwall.com/us/en/support/2213.html?fuzeurl=https://www.fuzeqna.com/sonicwallkb/ext/kbdetail.aspx?kbid=6368 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Please let me know if that works i been having the same issue.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi sniperwolf0117,

To avoid commandeering this thread, please go ahead and create a new one detailing your issue a bit more, and we will be there to assist! :D 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I don't know if you are still having this issue, but I managed to get it figured out here and I figured I would post the answer in case anyone else bumps into this.  I found the issue to be related to the Application Control security feature. You can disable the Application Control completely and the xbox will work, but that wasn't really an option for me.  Here are the steps to correct:

1: update the sonicwall to the latest firmware revision

2: set the xbox to a static IP address

3: create an address object for the xbox in the "Network" section

4: go to Security Services/Application Control

5: click "Configure App Control Settings"

6: click the box next to "Enable Application Control Exclusion List"

7: click the "Use Application Control Exclusion Address Object" radio button

8: In the drop-down, select the address object you created for your xbox.

Save and Done!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.