Comcast customer still disconnected

I haven't been able to log into my profile ever since the start of the big issue with Comcast. I figured I would wait it out until Microsoft gave the all clear, but they did and it still isn't working. At this point I've tried almost everything: clearing the cache, disconnecting and reconnecting, setting the network to factory defaults, rerunning the initial setup, and restarting the modem and router. I also tried deleting and redownloading my live profile, but I couldn't redownload my profile due to not being able to connect to my home network. Here's the rest of the information then-

I live in the United States.
The modem is an **** tm822.
The router is a Netgear WNR834M.
I am using a wireless connection and the adapter is the internal adapter for the Xbox 360 S
I don't know if UPnP is enabled or disabled.
I don't have a nat error.
The error code I get is 8015901 whenever I try to sign in and whenever I check connection it says Ip address error.
Our isp is Comcast Xfinity
W:0000-0021
X:4000-1001
Y:0000-0000
Z:0000-0000
ID:0001-0002
L:8015-1901
Q:8007-435
T:Wireless
D:0.0.0.0.
S:WEP
C:1
 

Question Info


Last updated July 4, 2018 Views 0 Applies to:

Hey AlphaBravoSquad,

It looks like your Xbox can't find the right IP.

I suggest that you set-up a static IP for your Xbox 360 Console.

You can do this the following way,

On your computer:

  1. Go to Start and type in CMD and press ENTER.
  2. In the CMD type ipconfig
  3. A whole bunch of numbers and things should come up, scroll up until you see the following values:
IPv4 Address: <Your IPv4 Address>
Subnet Mask: 255.255.255.0
Default Gateway: <Your Default Gateway>
Important: Note down these values.
On your Xbox 360:
  1. From the Dashboard, select Settings, and then select System.
  2. Select Network Settings.
  3. If prompted, select your Network Type (Wireless or Wired).
  4. Select Configure Network.
  5. Select IP Settings.
  6. Select Manual.
  7. Select IP Address and enter the IPv4 Address you wrote down.
  8. Select Subnet Mask and enter 255.255.255.0
  9. Select Gateway and enter the Default Gateway you wrote down.
  10. Select Done.
Let us know if doing this fixed the issue =)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This didn't work. I tried about 5 or 6 ip addresses from different devices on my wifi. I also tried changing the last 3 digits in case it conflicted with some of the other devices. None of these ip addresses worked.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Alphabravosquad you are not alone. Almost the same exact boat but I'm wired in via Ethernet cable. That and I'm connected to live, I just can't play any of my games: Halo 4, Halo REACH, nor COD Black ops. All come up stuck on the same or similar message "Checking downloadable content data..." or "Error incorrect data.." And Mr. Rep guy/person, I've tried your suggestions, Alpha's, and the rest around the forums. My Internet is working, wifi good, 360 only good for it's DVD player if that.. So I welcome anymore suggestions... Help... Please and Thank you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

[quote user="AlphaBravoSquad"]T:Wireless
D:0.0.0.0.[/quote]

According to this, the console doesn't get an IP address from the Netgear router.

Without a proper internal connection everything else will fail.

So try the following:

Go to the network settings of your console, and configure the network. On the screen where you choose to have the IP set automatically or manually, go right once more to the additional network settings.

There reset the network settings of the console to factory defaults.

Now find your WLAN SSID in the network settings and enter the correct WLAN passkey.

On the network configuration screen, make sure the console is recieving a proper IP address (usually starting with 192.168.xxx.yyy or 10.xxx.yyy.zzz.)

If it starts with 169.254.xxx.yyy the console doesn't have a proper connection to the router, and you might have trouble with your WLAN connection like outside interference or a neighboring WLAN broadcasting on the same channel.

To avoid that, just for testing purposes, connect your console with a LAN cable if possible. See if that connects your console properly online.

If the console was able to obtain an IP properly, do a connection test to Xbox Live.

If that test went through, clear the system cache again, and download your profile again.

See if you are now able to connect properly.

If everything works as expected, you can then return to the WLAN connection, and see if that continues to work.

If WLAN is giving you trouble again, try a different WLAN channel, or if surrounding interference is impairing your WLAN too much, keep using the wired connection (or use Homeplugs with Ethernet over Powerline adaptors if you don't want to run a cable through your home).

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Ok, so it works when wired up, but doesn't when I try to switch back to wireless. Is there any way to find and fix what is causing the problem or am I just going to have to keep it wired in?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

[quote user="AlphaBravoSquad"]Ok, so it works when wired up, but doesn't when I try to switch back to wireless.[/quote]

Then there is probably wireless interference causing your problems. Unfortunately, interference is "invisible" and "untouchable", so you can't find the cause with your normal "human" senses. You can't see the interference, and you can't push the wireless signals around with your bare hands. So you need some troubleshooting tools.

Some routers have the functionality, that somewhere in the Wireless settings they can show you a nice diagram, which displays on which channel neighbouring WLANs are broadcasting, and which are causing interference by broadcasting on the same or nearby channels.

If your router does not have this functionality, you need to download the free tool InSSIDer here. This will display on your PC surrounding WLANs, and what channels they affect.

Choose then the least crowded channel.

Also keep in mind, that a selected channel is several channels "wide". For example: a WLAN set up to broadcast on channel 4 will also affect channels 2, 3, 5 and 6 as well. So WLANs broadcasting on the channels 1, 2, 3, 4, 5, 6, 7 and 8 have some overlapping channels affected by the WLAN on channel 4.

Only the WLANs on Channels 1, 6, and 11 don't overlap each other.

Unfortunately, the free InSSIDer Tool can not show you interference coming from non-WLAN sources, like wireless baby monitors, cordless phones or other wireless devices broadcasting in the 2.4GHz frequency range. You would need to buy expensive hardware and the full version for that.

So if changing channels doesn't really help, probably other wireless devices and even Microwave ovens can interfere with the wireless quality of your signal up to the point where it becomes unusable.

If you are unable to get a working signal after trying other WLAN channels, you probably have a too "noisy" neighbourhood, making WLAN an impractical choice. So using a wired connection is advisable.

However if running a cable through your home is not an option, you might want to try so called "homeplug" adaptors, that run Ethernet over your home's powerline cabling in the walls.

For example Devolo makes such homeplugs. But there are other makers for homeplug adaptors as well.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

[quote user="AlphaBravoSquad"]Ok, so it works when wired up, but doesn't when I try to switch back to wireless.[/quote]

[quote user="AlphaBravoSquad"]Ok, so it works when wired up, but doesn't when I try to switch back to wireless.[/quote]

Then there is probably wireless interference causing your problems. Unfortunately, interference is "invisible" and "untouchable", so you can't find the cause with your normal "human" senses. You can't see the interference, and you can't push the wireless signals around with your bare hands. So you need some troubleshooting tools.

Some routers have the functionality, that somewhere in the Wireless settings they can show you a nice diagram, which displays on which channel neighbouring WLANs are broadcasting, and which are causing interference by broadcasting on the same or nearby channels.

If your router does not have this functionality, you need to download the free tool InSSIDer here (EDIT: Putting a direct link seems to cause this answer to be pushed in a moderation queue. Just Google search for "InSSIDer" to find the Metageeks homepage and download the tool there). This will display on your PC surrounding WLANs, and what channels they affect.

Choose then the least crowded channel.

Also keep in mind, that a selected channel is several channels "wide". For example: a WLAN set up to broadcast on channel 4 will also affect channels 2, 3, 5 and 6 as well. So WLANs broadcasting on the channels 1, 2, 3, 4, 5, 6, 7 and 8 have some overlapping channels affected by the WLAN on channel 4.

Only the WLANs on Channels 1, 6, and 11 don't overlap each other.

Unfortunately, the free InSSIDer Tool can not show you interference coming from non-WLAN sources, like wireless baby monitors, cordless phones or other wireless devices broadcasting in the 2.4GHz frequency range. You would need to buy expensive hardware and the full version for that.

So if changing channels doesn't really help, probably other wireless devices and even Microwave ovens can interfere with the wireless quality of your signal up to the point where it becomes unusable.

If you are unable to get a working signal after trying other WLAN channels, you probably have a too "noisy" neighbourhood, making WLAN an impractical choice. So using a wired connection is advisable.

However if running a cable through your home is not an option, you might want to try so called "homeplug" adaptors, that run Ethernet over your home's powerline cabling in the walls.

For example Devolo makes such homeplugs. But there are other makers for homeplug adaptors as well.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hmm. For whatever reason, my answer was put into a moderation queue, although I left out any links to external sites. You will just have to wait until the answer gets moderated and published. But a short summary:

[quote user="AlphaBravoSquad"]Ok, so it works when wired up, but doesn't when I try to switch back to wireless.[/quote]

Change WLAN channels and if all else fails get homeplug adaptors for ethernet over your house's powerline cables.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Keep it wired. Better connection.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.