Cant get sound from Xbox to come through my Razer Chimeara 5.1 Headset!!

Hello,

I recently bought the Razer Chimeara 5.1 headset so I can use on both my PC and 360. I can use my headset as a mic but for some reason I cant get the sound from the xbox to come through my headset as well. I unplugged the PC cords from the base and plugged in the optical cable that came with headset into the back of my 360 slim and then into my base.

If i'm doing something wrong, someone help?

Thanks.

 

Discussion Info


Last updated July 4, 2018 Views 5 Applies to:

I have the chimaera 5.1s aswell I got them working fine then just now they stopped giving out audio :( searching for a solution...

check the audio options on the xbox.

Start the Xbox 360 console without a disc in the disc tray.

Go to the Settings hub, and choose System.

Select Console Settings, and thenselect Audio.

i know with my turtle beach ones i needed to change a setting

First Step:

Make sure all the required cables are plugged in, for example an optical cabel from the Optical In port on the Base Station to the Optical Port on your Xbox 360, and then turn on the Base Station (Center Button). For assistance check out: 

http://help.razersupport.com/us-en/resolution.asp?sid=084342120527082073111070&pid=400001075&pnm=Razer+Chimaera+5%2E1&seid=400002872&pos=Xbox+360&top=Setup&rid=400003729

 

Second Step:

Make sure the Chimaera 5.1 Wireless Headset you are using is synched with it's Base Unit. If it isn't or you are unsure check out: 

http://help.razersupport.com/us-en/resolution.asp?sid=084342120527082073111070&pid=400001075&pnm=Razer+Chimaera+5%2E1&seid=400002872&pos=Xbox+360&top=Setup&rid=400003730

 

Third Step:

On your Xbox 360 make sure the Digital Output is set to Dolby Digital 5.1. If it isn't or you are unsure then:

  • Press the Guide button on your controller, go to Settings, and then select System Settings.
  • Select Console Settings.
  • Select Audio.
  • Select Digital Output.
  • Select Dolby Digital 5.1
 
Fourth Step:
Turn on the Chimaera 5.1 Wireless Headset by using pressing and holding the Power Button (Bottom Button on the Microphone Ear Cup). Look at the buttons on the Non-Microphone Ear Cup and check if Mode & Mute/Synch Buttons are NOT lit up. If either or both of them are just press the lit button.
Your audio issue should be resolved by now.

Same problem here, did all the steps and I still not work. I have the xbox hdmi to tv and xbox digital audio to chimaera base and the sound still comes out of the tv and no sound in the headset...

Im having the exact same problem please i need help only got them yesterday and still the sound comes from the tv not the headphones. PLEASE I NEED A SOLUTION