Can't connect to xbox live

What Country/State/Province do you live in? 
Santa Clara, California

Modem brand & model number: 
Arriss TM402P

Router brand & model number: 
Netgear WNR1000v2

Network Connection Type: Wireless/Wired
Wired

If Wireless, what type of encryption are you using? 
N/A

Things you have tried: 
Is UPnP Enabled? Yes/no/Unknown
Yes

Is NAT Type Open? 
I don't know what this is and cannot find a NAT type setting in my router.

(My ports are forwarded though)

Any Error Codes you encounter: 

Can't obtain an IP address from your router or modem.

If I assign a static IP, it says a static IP doesn't work with my router.


What type of internet do you have? Cable/DSL/T1/3G? 
Cable

 


Who is your ISP(Internet Service Provider)? 
Comast XFinity

When you run "Test Xbox LIVE connection" what is the exact message shown on screen? 
Can't obtain an IP address from your router or modem.  

 

Thanks for any help guys

 

 

Question Info


Last updated July 4, 2018 Views 2 Applies to:

More Info:

If I manually set my network settings (IP and DNS), it now connects to the network, but fails at the connecting to the internet step, with this error message:

Your DNS server can't resolve the names of Xbox Live server or Xbox.com

I can connect fine from my laptop running wirelessly from the same router.

Also, one more thing is that the xbox, oddly, doesn't show up under attached devices in my routers admin page

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Also, if I connect my laptop to the router using the same wired ethernet cord it connects to the internet fine.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Go to Configure Network and Additional Settings.  If there's anything there other than "not set", restore to factory defaults.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Everything was already on "not set".

Any other ideas? Thanks for the help

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Please take a few minutes to check out this guide on DNS issues, to see if it helps.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

 

In this very standard set-up you should have no issues with an ip address, please restore your Xbox network settings to factory defaults and try again

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

you manually set you ip....did you enter the gateway address and subnet mask? As with fowarding on most routers with upnp enabled, you can get open nat by fowarding port 3074 tcp/udp to your xbox ip.  also make sure that the static ip you are using never has the chance to get auto-assigned to another device on your network.

If you are not sure is your manual settings are right, then set the box to automatic to see if it connects. I know it might be strict nat but that will tell you that your values in the settings are wrong.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.