Can't connect to Xbox Live on my Xbox S 4gb with my NetGear wrn2000 v2

What Country/State/Province do you live in? Quebec, Canada
Modem brand & model number:
Router brand & model number: Netgear wrn2000 v2
Network Connection Type: Wireless
If Wireless, what type of encryption are you using?
WPA-PSK [TKIP] + WPA2-PSK [AES]
Things you have tried: Everything xbox.com/networlhelp told me to try
Is UPnP Enabled? Yes
Is NAT Type Open?
Any Error Codes you encounter:
What type of internet do you have? Cable
Who is your ISP(Internet Service Provider)? Videotron 
When you run "Test Xbox LIVE connection" what is the exact message shown on screen? A problem with your connection occured blablabla

 

 

So yeah, everything with my internet and router is fine, I'm connected with my laptop and a desktop computer on the same network, works perfectly fine, somehow, my new Xbox S won't take it and won't connect. I had the ethernet cable before and it worked fine, but now that I try to be wireless, problems, it sucks. Anyone can help ?

 

Question Info


Last updated July 4, 2018 Views 2 Applies to:

Hey mate, unfortunately that "blablabla" is very important to us. Can you please list what it says exactly, and what it says under more info? Also, how far is the Xbox 360 from your router? Depending on the error message you're receiving, you may want to try placing them in closer proximity to each other.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.