Cannot connect to xbox live using WPA/WPA2 security on Belkin N750 Router have to downgrade to WEP

 

I have 2 wireless networks running.  The one I am going to shut down is the Linksys network, the one I am going to keep I will call Belkin network.  The Linksys network connects fine, the Belkin network will only connect if I downgrade it to WEP security, set up a static IP address and configure Virtual Servers.  What a pain! 

I am thinking of returning the Belkin and going with a different router.  Am I missing something?

Linksys Network: 

Linksys Wireless-G Broadband Router,  WPA Personal, TKIP  - connects

Linksys Wireless-G Broadband Router,  WPA2 Personal, AES - connects

Belkiin Network:

Belkiin N750, WPA / WPS2, AES - fails

Belkiin N750, WEP - connetcs (only if using static IP and virtual servers)

 

 

Question Info


Last updated July 4, 2018 Views 1,562 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Talked to Belkin Tech Support.  Beware, they said some xboxes work with WPA some don't.  Some Vista machines work with WPA some don't.  Their standard solution is to downgrade to WEP.  Not sure if the tech was just trying to get me off the phone, but he said this could change in some future firmware update.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

What Belkin Tech Support failed to tell you is a lot of their routers don't get on with the Xbox adapters, the Xbox supports WPA no problem. What is the model number of Belkin underneath the router, it will start with F

 

Do you have an option for WPS? If so turn it off. Also have a read through these:-

 

www.unofficialguidetolive.co.uk/.../166-wireless-gaming-official-wireless-adapter-incompatibility-list

www.unofficialguidetolive.co.uk/.../114-troubleshooting-and-improving-wireless

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The Belkin Model is F9K1103v1.  The xbox has built in wireless and was purchased recently.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Just got this router... was very excited to hook it up. Unfortunately, none of my devices support the 5GHZ mode... but that's not the worst of it. I can't connect wirelessly to Xbox 360. It won't even go past the first step. The PS3, iphone, and my laptop connect fine. So, does this router go back tomorrow to Target, or is there a solution? And no, I won't change to WEP.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

@ Both

 

Can you try this:-

  1. Get the latest firmware and use it:- en-us-support.belkin.com/.../5359
  2. Turn off WPS (if its on)
  3. Turn off an mac address/wireless station filtering
  4. Turn off WEP/WPA/WP2 (just as a test)
  5. Try to connect
  6. If that works ok turn on WEP
  7. Try to connect
  8. If that works ok turn on WPA2-PSK (AES) or (AES+TKIP)
  9. Try to connect
  10. If its still not working ensure the router is broadcasting in 2.4Ghz only
  11. Try to connect

Please let me know if that works or where it fails

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I just got it to work with WPA with 5GHZ turned off. I wonder if the problem is the dual band existing, or WPA2, or both. I'm going to try a few things out.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I turned the 5GHZ channel back on after I connected the Xbox 360 via WPA encryption and it worked. So it's not the 5GHZ band. Maybe you have to disable 5GHZ, connect your Xbox, and then turn 5GHZ back on. One more test to run... trying out WPA2 instead of WPA.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I figured it out. If you use WPA2 encryption, the Xbox 360 will not be able to connect via wireless. It does not matter whether or not you have the 5GHZ option enabled or not. If you use WPA Personal, the Xbox 360 can connect. Out of the box the router is set up with WPA + WPA2 encryption. Is there any huge advantage to using WPA2 vs WPA1? If there is, I'll take the router back tomorrow for a NetGear.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I should mention I'm using the Xbox 360 Slim, 250GB. There used to be a problem with Xbox 360 that it would not work with WPA2 encryption. Back in 2009 there was a patch released that added the functionality. I don't know why it doesn't work now. But I have WPA working.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Also should note WPA2 only has an AES option, nowhere can I select TKIP on the Belkin router. Why?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.