Can't download a game.

I can't seem to download Black Ops III Beta. I went to the network diagnostic tool to discover I have a 173 Mb download, 12 Mb upload, with 0% packet loss, but I can't get past 1% on my game download. I checked the current statistic: it says I'm downloading at a rate of 100 Kb - 1.5 Mb. The odd thing is when I refresh the page (Go back. Open back up) It says I downloaded 300 Mb in a couple of seconds, but my download is still on 1%. I went to Power option and restarted my Xbox. Completely restored my router. Cancelled and deleted the game to try again. I also turned off my Xbox and unplugged the power brick. I finally tried my WiFi (currently using Ethernet) I connected to my 5 GHz and 2.4 GHz averaging around 90 Mb down and 10 Mb up, but the game is still not downloading. Shows the Xbox downloading something, but not the game... Please help. Thanks

Keep getting error when trying to upload images. I uploaded them to imgur:

http://i.imgur.com/4IJcv4Um.jpg

http://i.imgur.com/DTMgFVTm.jpg

http://i.imgur.com/8xYP41wm.jpg

 

Question Info


Last updated July 4, 2018 Views 26 Applies to:
Answer

Hey there Registry Editor!

We have received reports that this issue has been resolved. Be sure to let us know if you are continuing to experience download issues. Thanks in advance!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.