Can't connect Xbox live (Comcast)

It looks like I have the same issue as lots of users who have Comcast. Starting Monday, 11/11, I have been unable to maintain an Xbox live connection. Once I turn the Xbox on, it logs in. But very quickly I get disconnected. I have done the modem/router resets, power cycle, cleared the cache on the Xbox. Sometimes when I check network connectivity, it works fine. Other times I get a ICMP error. Other times the error code is 80151909.

In looking at Xbox forums and Comcast forums, it's obviously a Comcast issue. But when I call them, they want to charge me 79.99$ for Level 2 support to "align" my home network. I call BS.

Does anybody have a solution to the problem?
Thanks! 

 

Question Info


Last updated July 4, 2018 Views 45 Applies to:

Comcast is working on the problem! Hopefully it gets fixed soon

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Xbox support said something about reconfiguring the ports on the router/modem (there's a "fee" for that too now apparently). My problem is that it XBL barely stays connected for more than a minute or 2. Long enough to delete my profile and all updates, not long enough to download my profile or install the updates.

By the way, this is day 3 of this problem.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

G'day Gnome! Sorry to hear about your connection issues. Can you please provide the info requested in the link that AX3TASTIC provides? It will help us take a look at your connection and find the cause of these disconnections, and we can keep working from there. We'll get you back online!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Joust, I'll post the info below. But it does look like I may have solved the problem (with some help from Xbox support).

After trying a whole series of solutions (deleting profile, uninstalling updates, etc) I kept getting the same problems (connection for maybe a minute, then disconnect). Sometimes when I ran  the Network connection test I would get error code: 80151904, sometimes 80151909, and even an ICMP or 2 (never a NAT error). Xbox support suggested I contact my ISP (Comcast) and have them "Reconfigure the Ports". When I called Comcast, they still wanted a fee for this service. So in a fit of inspired anger, I turned on the xbox, went to settings and decided to try a fixed IP. I manually set the IP in a range that was available with my modem/router (in  this case it had been XX.XX.XX.1, I then changed the 1 to a 7). Then, magic. I could connect. I could re-download my profile. I could install updates. And I remained logged into XBL for over an hour, no issue. Obviously changing the IP address worked (but I don't know if it was in combination with all the other solutions).

Here is the info:

What Country/State/Province do you live in? USA/Pennsylvania

Modem brand & model number: Arris/TG852G/CT

Router brand & model number: same

If Wireless, are you using a white or black external adapter, or an internal (Xbox 360S) adapter? Internal

Things you have tried: reset router, power cycled router, deleted profile, uninstalled updates; cleared cache 3X; weeping

Is UPnP Enabled? Yes/no/Unknown Unknown

Do you have a NAT error? If so, what is your NAT type? No

Any Error Codes you encounter: 81051904, 81051909, 8007274c

Who is your ISP(Internet Service Provider)? Comcast

After you run "Test Xbox LIVE connection" press “Y” for "More Info”. In the pop-up that appears, what are the following values, if shown? (If a value below does not appear for you, just leave it blank.)

W: 0000-0021

X: 0000 - F001

Y: 20A8-4840

Z: 0000-0000

ID: FFFF-FFFF

L:8015-1904

Q: 8015-100c

T: Wireless

D: 75.75.76.76, 75.75.75.75

S: WPA2

C: 1

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey glad to hear changing the IP fixed it for a bit. Did it still drop out after an hour or so though? 

Have you tried a direct wired connection? If not, let's give that a shot and see if it makes any difference.  

Also, let's go ahead and try disabling the firewall, as this may be another facet of the issue. Here's how: 

  1. Open a web browser.
  2. Enter http://192.168.0.1 or http://10.0.0.1 in the address bar. (Or click one of the links)
  3. Enter the username and password if the gateway asks. (admin/password)
  4. From the menu on the top select Wireless.
  5. From the submenu on the top select Firewall.
  6. From the menu on the left select Firewall Settings.
  7. Uncheck the boxes for Enable Firewall and Enable DoS Attack Protection Firewall.
  8. Select Apply.

 
As a resource, here is a complete overview of your gateway device: Arris TG852GCT

Let us know how that wired/firewall goes, and we can work from there.  

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Ohnaka

I was able to stay logged on and connected indefinitely since I changed the IP address. I played LFD2 in a friends game, using Party chat with no issues. In fact I noted 2 hours 42 minutes of game time, with no disconnects or any other issues.

I have not tried a direct wired connection, but will try that shortly.

Re: disabling the firewall. Is that a temporary fix or something that would remain disabled indefinitely? When I originally signed up for comcast service (back in July) I made no changes to the default settings on the modem/router and had no connection issues for 4 months. I assume the firewall was enabled that whole time.

Are there any issues with issuing a static IP address for the xbox? I have not had any other device conflict issues (2 laptops, android phone, ipad have all connected since assigning  static IP to the xbox).

So far it all works. I will report back on the wired/firewall attempts (although I'm nervous to make any further adjustments since I have finally been able to reconnect).

Thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.