Can't connect with my friend's online game.

I'm trying to join in an online multiplayer game of Dead Island and I can't get connected with my friend. Both of us are connected to Live, and he is currently in the game with another friend of his, but when we try to connect it says that the connection failed. This isn't the first time it's happened, but the last time we managed to finally get connected after a few tries. When I accept his game invite, it will start to connect and give me a loading screen where it is trying to connect, and I can even hear him talking to me over his headset, but then the moment the loading screen goes away, it gives me a message saying that I couldn't establish a connection with him.  We are on the same network, so why are we having such a hard time connecting to each other?

 

Question Info


Last updated July 4, 2018 Views 1,035 Applies to:

Either one or both of you have a NAT issue.

Run the Xbox Live connection test any report back any NAT results.

For more on Moderate and Strict NAT results check here.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Greetings TheBadPiLL!

Before we begin troubleshooting, I would like you to answer a few questions that will help us solve your issue. Please read: START HERE! And post back in full detail (the bits that are in bold).

Thanks! 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi, sorry to read you're having problems. Since you have been connected before and worked fine, I would advise you to clear your cache. support.xbox.com/.../clear-system-cache. Also, make sure to unplug your router and modem for 30 seconds and replug in. Try this first and I hope it helps. If not, please respond again, we are always happy to help. Game on!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.