Can't connect to Xbox Live

Please help

For some reason I have not been able to connect to Xbox Live all day. I have tried every single possible way to make it connect, with no luck. I get the MTU error when running the test, but this should not happen as my current MTU settings are at 1364, although they were even higher before I started messing with it, since it wasn't connecting. I have tried 1364-1500 in 25 increments, but nothing seems to work. The strange part is, sometimes it will not give me the MTU error, and will actually connect to the internet, but then, it will just tell me that it cannot connect to xbox live. My xbox is the only thing on the network, and it is plugged in via cable, so I do not see why it is not connecting. I can use the internet on any other device, so I know that there is nothing wrong there. All of my ports are forwarded as well. It was working perfectly fine the last time I tried it on tuesday morning, and nothing has changed from then to now, so I am completely confused as to what could be happening.

Please help

 

Question Info


Last updated July 4, 2018 Views 0 Applies to:

Hi,

Who is your ISP, has this just started today? You will find most of the time MTU errors are not actually problems with MTU it is the Xboxes way to say it can't connect for some reason.

Have you tried powering down your modem and router and then powering them back up again?

MTU errors like this are usually temporary, you may find it works again on its own soon

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

According to Xbox Live service status: support.xbox.com/.../xbox-live-status everything is up and running. It may be an issue with your router, have you tried resetting it or updating the firmware? I had problems with connections suddenly (without ever making changes) and it turned out to be a router issue.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Have you called the ISP and asked them to trouble shoot your modem? Mine had to replaced. Would allow the laptop to work but the xbox would drop at odd times.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I think i have been that problem before. Just follow this steps. maybe it will work.

1. Go to Your modem Restart your modem. Remove all the Connections.

2. Turn off your xbox 360. delete all the cache. its ok.

3. wait for 30 minutes.

4.after that Turn on your modem. if you have a wired connection . connect it to your xbox

5. then check Your Internet connection.. TADDDAH!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi all, thanks for all the suggestions, but unfortunately none of them worked, I even unplugged the router and the xbox for the entire night, and when i tried again this morning, I am still getting the error. @AssassinG1997, I tried your idea to but it to did not work. I literally have no idea what to do now, if it is of any help to anyone, my router is a d-link dls-2640U

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

ok, I got it to work, what I did was backup all of my router settings, then manually reset the router, not by switching it off or on again, but by holding down the reset button so that it removes all settings itself from the router, then after it rebooted I reloaded all of the previously backupped files, and it went online.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Excellent :o)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

@ColonelCrackpot hello yes i was saying that your restart/reset your Modem. :) thanks anyways

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Glad to hear you were able to get this resolved, Colonel! Happy gaming to you! :)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.