Can't connect to XBOX live. Xbox doesn't get IP-address

Hello,

Last week I came back from my holliday and all of a sudden my XBOX won't connect to XBOX live anymore. It seems like it doesn't pick up the IP-adress assigned to it by my router (my router assigned 192.168.1.121) . I tried using an other router (airport express) but without success. When I use my IPhone as a hot spot I am able to connect to XBOX live. After my holliday I applied the necessary updates and I think that this may caused the issue.

A wired connection to the same router does work!

What Country/State/Province do you live in? 

Netherlands/Zuid-Holland/Rotterdam

Router brand & model number: 

TPlink w1043nd or Apple Airport Express

If Wireless, are you using a white or black external adapter, or an internal (Xbox 360S) adapter?

Internal adapter

Things you have tried: 
Is UPnP Enabled? Yes

Do you have a NAT error? If so, what is your NAT type?

Any Error Codes you encounter: 

Can't obtain IP-adress from router or modem

Who is your ISP(Internet Service Provider)? 

UPC

Thanks!

 

Question Info


Last updated July 4, 2018 Views 1,094 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Greetings Tornado!

Could you start by making sure your TPlink router is up-to-date with the latest version of firmware. Visit the manufactures website and check for a software update.

If you haven't already, restore your Xbox network settings to factory defaults. Navigate to Xbox network settings and Additional Settings tab. Select restore network settings to factory defaults.

Let us know how that goes and we'll work from there.

Thank you! 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello if your Xbox is not getting an ip address it may be an incorrect network setting

On the Xbox go to System > Network Settings

Click "Configure" and set the ip address and DNS to Automatic

then on your PC access your router setup page (see the manual)

Find the Setting called DHCP and make sure its enabled si your Xbox can receive the correct settings

Also make sure you have UPnP enabled in the router

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for the sugestions. But I already tried those. My PC and smartphones have no trouble connecting and using a cable it's also working. I also tried assigning a ip adres manually and it still doesn't work. I can see that my router has assigned an ip adress in the dhxp client list by the Xbox just doesn't pick it up. The funny thing is though when assigning an ip adres mannually I can the the the primary Dns entry going on and off from 192.168.1.1 to 0.0.0.0.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

While you troubleshoot, do not manually assign your Xbox static network settings.

Which of the following two routers are you currently using? TPlink or Airport?

Follow the steps up front and let me know what IP address your Xbox picks up from the DHCP.

Power off your router for a couple of minutes. Turn on your router and wait one minute for it to connect properly. 

Turn on the Xbox and restore Xbox network settings to factory defaults.

  1. Press the Guide button on your controller, go to Settings, and then select System Settings.
  2. Select Network Settings.
  3. Select Wired Network if you are prompted to do so.
  4. Select the Additional Settings tab.
  5. Select Restore to Factory defaults.

Reconfigure Xbox wireless settings.

Go to Xbox network settings and select Test Xbox LIVE Connection.

After you run "Test Xbox LIVE connection" press “Y” for "More Info”. In the pop-up that appears, what are the following values, if shown? (If a value below does not appear for you, just leave it blank.)
W:
X:
Y:
Z:
ID:
L:
Q:
T:
D:
S:
C:
 

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Taidara,

Thanks for your help. I am currently using the TP-link router. From the DHCP Client list on my router I can see it has assigned 192.168.1.109 to the XBOX's MAC adress. So the router is giving out an IP-adress to the XBOX.

The Error status Report show the following:

W: 0000 - 0000

X: 8000 - 0011

Y: 0000 - 0000

Z: 0000 - 0000

ID: FFFF - FFFF

L: 8015 - 1000

Q: 8015 100D

T: Wireless

A: 0.0.0.0/0.0.0.0

G: 0.0.0.0

D: 0.0.0.0, 0.0.0.0

N RVBWLAN

S: WPA2

C: 11

Hope this helps you to figure out what's going wrong.

Thanks!!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Could you also post up the make and model of your modem as well.

Could you reset your router to factory defaults and reconfigure wireless settings.

Unplug all devices from your router (except the power supply). Press and hold the reset button for 5 seconds and wait for the router to reboot.

Plug in your computer and access the web utility interface for this device. Do not use a setup wizard that let you configure wireless settings automatic. Instead, do it manually. Select a name (a single word) for your wireless network (SSID). Select WPA2-PSK with AES encryption as the method to secure your wireless network. Save/Apply.

Make sure UPnP (Universal Plug and Play) is ticked enable/turned on. Save/Apply. Reboot the router and wait one minute for it to connect properly.

Start your Xbox and go to Xbox network settings. Select the Additional Settings tab and select Restore to factory defaults.

Reconfigure Xbox wireless settings.

Post back and let us know how that goes. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I finally figured it out. It had to do with wrong time-settings. I corrected the time-zone and added a time-server to my routers time settings and finally go connected. Anyway thanks for your help.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

To bad. Started the XBOX today and again no IP-adress. I still think it has something to do with the last update. In the router log I can see it assigns an IP adres and sents an ACK to the XBOX however the XBOX's keeps requesting for anIP:

178 Sep 8 13:39:22 DHCP NOTICE DHCPS:Recv DISCOVER from 00:25:AE:E9:D7:86
177 Sep 8 13:39:22 DHCP NOTICE DHCPS:Send ACK to 192.168.1.102
176 Sep 8 13:39:22 DHCP NOTICE DHCPS:Recv REQUEST from 00:25:AE:E9:D7:86
175 Sep 8 13:39:22 DHCP NOTICE DHCPS:Send OFFER with ip 192.168.1.102
174 Sep 8 13:39:22 DHCP NOTICE DHCPS:Recv DISCOVER from 00:25:AE:E9:D7:86
173 Sep 8 13:39:22 DHCP NOTICE DHCPS:Send OFFER with ip 192.168.1.102
172 Sep 8 13:39:22 DHCP NOTICE DHCPS:Recv DISCOVER from 00:25:AE:E9:D7:86
171 Sep 8 13:39:21 DHCP NOTICE DHCPS:Send ACK to 192.168.1.102
170 Sep 8 13:39:21 DHCP NOTICE DHCPS:Recv REQUEST from 00:25:AE:E9:D7:86
169 Sep 8 13:39:21 DHCP NOTICE DHCPS:Send OFFER with ip 192.168.1.102
168 Sep 8 13:39:21 DHCP NOTICE DHCPS:Recv DISCOVER from 00:25:AE:E9:D7:86

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Just changed the router firmware to DD-WRT to see if that would solve the issue, but without result. Still no IP! To me this is clearly a XBOX issue as non of my other wireless clients experiance any problems at all.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

WIth your Xbox powered off, safely remove the hard drive and add it back. Turn on the Xbox and go to System Settings. Select Initial Settings. Set the correct values for Language, Local, Time and date.

If that fails, try temporarily to disable the security method on your router to see if you can connect properly.

Keep us posted! 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.