Can't connect to non Open NAT Friends

I've been trying to solve this for ages and it's driving me mad so I'm hoping you clever people can help me.

I have an ADSL Plusnet broadband connection running at 0.75mbps (due to my rural location) this connection is dedicated to my 360 and nothing else in the house uses it.  I have a Belkin Enhanced Wireless Modem Router (F6D4630-4 v2), which is badged as "Vista Compatable", connected via ethernet to my 360.

With the Xbox Network settings all set to Automatic and the UPnP enabled on the Router the Xbox Live Connection Test reports that my NAT is Open.  However, I am unable to connect to some members on my Friends list who have Moderate or Strict NATs and it takes ages to find a game in public matchmaking.

If I switch off the UPnP, set the Xbox with a Static IP address and manually forward the ports my NAT goes Strict.  Basically any combination of manual settings that use a Static IP for the xbox (Firewall On or Off, Deny Ping to WAN Interface On or Off, DMZ On or Off) NAT is strict.

I have used the www.portforward.com tutorial to set up my router manually and I have tested all the Xbox Live ports through that router using my laptop and the PFPortChecker tool and all report as open, provided they are forwarded.

I have one Friend who I can connect to, no matter what, who uses a Static IP address, no UPnP and has no Firewall on his router.  His Broadband connection is through Virgin. I have to use him as a go-between to play with any other Friends on my list.

I have another Friend who up until yesturday had his NAT reporting as Moderate and I could not connect to him at all, Party or Games.  He has forwarded the relevant ports on his router, his Xbox now reports his NAT as Open and we can connect & play.

Also, when I first turn on my Xbox and it connects to Xbox live, if I load a game (I have tested GoW 2, GoW 3 & Bulletstorm) and go to the Multiplayer lobby the game says my NAT is Strict. If I come out of the game run an Xbox Live Connection Test, which reports my NAT as Open, and then go back to the game. The game lobby now says my NAT is Open.

Can someone please help me?

 

Question Info


Last updated July 4, 2018 Views 6 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi,

So if you use UPnP on its own (no DMZ no forwarding) you can play against others with no issues (with the exception of these friends you mention) is that right?

If so its really for these friends to rectify their own NAT situations really

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

No, If I use UPnP the Xbox Live Connection Test "Says" I have an Open NAT but I am still unable to connect to anyone who does not have Open NAT.  As I understand it, if my NAT is Open I should be able to connect to anyone regardless of their NAT status and this is not the case.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

That is supposed to be the case but it doesn't always work out like that.

If UPnP hasn't work or portforwarding, follow these instructions exactly to the letter:- www.unofficialguidetolive.co.uk/.../62-my-nat-is-strict-or-moderate

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I've tried the UPnP Off, Static IP & DMZ thing and all that happens is the Xbox Live Connection Test Reports that my NAT is strict.

If the Open NAT status does not resolve all the connection issues do we know what else might be the culpret?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Have you tried those instructions exactly? Many Belkin N's suffer the same problem and I've not seen one not fixed by that guide.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yes I have tried those instructions exactly. Well except that I used 192.168.2.100 and not 192.168.2.120.  As I said in my orginal post any manual settings that do not use UPnP result in the Xbox reporting a strict NAT.

Are you suggesting that despite my Xbox reporting that the NAT is Open, when using UPnP, there could still be something in the router that is causing it not to be?  If this is the case why does the xbox report it as open if it is not?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

So its not exact then :)  .100 is still within the DHCP scope which some routers don't like which is why mine says .120

I'm not saying it will fix it but please change the Xbox ip address and DMZ address to .120 you should certainly be able to get an Open NAT when using a DMZ with no forwarding and UPnP turned off

As for your second question yes, I've seen the Xbox misreport its NAT status before, I've even seen it say its Open when its sat behind two routers and double NAT'd

I'm not saying that is the fault of the Xbox, it can only read what its being told and sometimes the routers don't use UPnP properly so don't report the info to the Xbox properly

There doesn't appear to be any new firmware for that router as you using 1.00.02?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have set the DHCP range of the router to 192.168.2.2 - 192.168.2.50 so in my case 192.168.2.100 is already outside of the DHCP range.

I've already updated the Firmware to the latest version which is 2.00.25 dated October 2009.  The router came with 2.00.20 and from what I can find out from the Belkin Website the only difference is the addition of the Turkish language in the GUI.

I have tried some more tests this morning using a Laptop and the PortForward.com Port Checking Tool.  With the Xbox switched off, I have removed all manual port settings, set the Firewall to Enabled, set Block Ping to WAN to disabled, set UPnP to disabled and power cycled the router.

Reconnected the Laptop, put it in the DMZ and tested the Xbox Live ports.  All ports report as open & reachable except for 3074 UDP which reports as blocked or unreachable.

I have raised a support question with my ISP (Plusnet) about the blocked port but fully expect them to tell me they do not block Xbox Live ports.

It's good to see that someone else has seen the Xbox misreport it's NAT status because I am pretty convinced at this point that my NAT is not actually OPEN.  I'm assuming if this is a problem with the UPnP implementation in some routers that by bypassing the UPnP I am likely to get a more acurate NAT status from the xbox?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Ok thanks, Plusnet don't block anything no. Yes some routers have a poor implementation of UPnP. Quite a few of the Bellkin routers just don't get on with Xbox in general but you can usually solve this with a DMZ.

Based on your laptop testing and the fact that there's no new firmware available then I'd say your out of options on that router really and would have to replace it.

You could as a final clutch at straws reset the router to factory defaults (that will loose all of your settings including the Plusnet username/password, so make sure you have this handy as you'll need it again) and then get reconnected to the net and follow that DMZ guide again.

Its worth a shot but I'd say your only option to resolving this would be to get a better router. :(

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

As expected PlusNet have come back and said they don't block any ports.

I was pretty much coming to the same conclusion as you but as I have only recently bought the Belkin router I was in denial about having to replace it.

I've looked through your Equipment recommendations and wanted to ask do you still stand by your recomendation of the Dlink DSL-2640R?  Is this still a router I should be looking at or is there something newer that works any better?

Thanks for all your help so far.

Also, If I mark your last reply as the Answer to my question, will it lock the thread and stop us discussing router options or will we still be able to get this finalised?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.