Can not connect to xbox live

Hi

I have been having a connection error to xbox live for the past two days, after calling support twice and my internet provider twice I am getting to the end of my teather!

I finally made a connection last night at 11PM after the console told me I had missing/corrupt files and would need to restart, then an update and finally another update and hay presto a connection.  Only to then turn it off after finishing my game and having to perform the same things tonight!!  Again it was only at 10.30PM I finally had a connection after missing/corrupt files sorted and updates compelete.  I will add after trying to update for 2 hours each time failing! 

I'm new to xbox live, is this normal to have to update daily?  I have checked the ports are all open and added the ones advised by support but still have to update the missing files and xbox live everytime I want to play a game, even though I have an internet connection.  Surely there is something wrong here?  Support are telling me its the internet provider and my internet provider are telling me it's xbox.

If it helps at all I use Orange internet provider and an Invertal router!

Please someone help me I have had a very unhappy son for the last 3 nights.

 

Question Info


Last updated July 4, 2018 Views 24 Applies to:

I am concerned with the message of having missing or corrupt files.  How old is your xbox?  It is not normal to have an update every day.  It seems like there is an issue with saving information.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It sounds like to me that in terms of having to "reupdate" all the time is a full system memory cache. Below is a link explaining how to do it and it should help you clear up the update issues your having. As far as the corrupt or missing files go....not to sure about that one, but try clearing the system cache to see if you can knock out two problems at once :D

(forums.xbox.com/.../98516.aspx.)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.