Belkin Wireless Router Won't Connect

Sup, my Belkin 801.11g router used to connect Xbox Live just fine but whenever I attempt to now it tries to connect to some random network with a long @@@ IP address. The network clearly doesn't exist, yet no matter what I do it will never connect to the main router downstairs. I've tried connecting manually also, but that doesn't work either. I gave up trying to play Xbox online some time ago and simply used the PS3 to play online instead, but there are a few games I would like to play online on my Xbox so the problem has resurfaced.

I have no idea what to do, I've tried everything including connecting my Belkin wireless adapter that I use on my PC to my Xbox, but the Xbox doesn't acknowledge it. On a side note, what's up with that? I've gotta buy overpriced Xbox only hardware to play online? You've already gotta buy Xbox only chargers, HDDs, headsets, currency and whatever else on top of the needless subscription fee. I guess it's too much to ask that I save £50 by using one of the many routers I have in the household.

Anyway, anyone got any suggestions for my router?

 

Question Info


Last updated July 4, 2018 Views 2 Applies to:

Hi,

 

Please read:- forums.xbox.com/.../9.aspx

 

And post back your details in full (the bits that are in bold on that post) so that people may help

 

If you are wireless can you also state whether you are using the white or black external adapter or the Xbox 360S Internal adapter

 

Thanks

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.