BELKIN ROUTERS

Country: USA

Router brand and model number: Belkin N750DB

Connection: Wireless

Encryption: AES

UPnP: Unknown

NAT: I'm not sure. I just purchased this router today.

Internet: 3G

ISP: Comcast

When I try to connect to xbox live, it doesn't even connect to the first step, the router. I have tried everything in the xbox.com/support section for wireless connection. This is a new router. My brother's xbox is hardwired and connects to xbox live, but mine is wireless (the new slim version) and it cannot connect. I had no problem connecting when I had a linksys router... please help me if you can, I have tried so many solutions for about 3 hours now. 

 

Question Info


Last updated July 4, 2018 Views 52 Applies to:

Hi, what is the code printed underneath the Belkin it will start with a F

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Try changing the wireless security type to either WEP or No Security.  If it's one of the f9k series, it has issues with both WPA and WPA2 security.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I just bought the same router yesterday and am having the same problem. If I plug the xbox directly into the router it connects and works great. If I try to connect wirelessly it doesn't even connect to the router. I have 3 other computer connect to the router wirelessly so I don't know why the xbox is having such a hard time. The code on the bottom of the router is F9k1103. What's the deal with this? I've tried calling belkin support but they always think i'm trying to forward ports and try to walk me through that process. I feel like there's some wireless setting that if changed, can fix it but I don't know what it would be. I'd really appreciate help on this as well. If you need to know more info about my setup just ask. I really want to get this solved.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

ok man, if you see below I had the exact same problem as you, same router, same isp, same connection type, same everything, and I was going crazy trying to figure out what was up. HOWEVER, I just got mine fixed! By the way if you're going to call Belkin's 24/7 router help line, call in the daytime; that's when they have their A-teams working apparently. Ok so it looks like it's an encryption problem, or atleast I was told, I'm no expert with this stuff. So I'll go through the steps Belkin had me do:

1.) go to your router setup page. Type in the default ip address for your router in your internet browser, it'll be something like 192.168.2.1 and then hit enter. Login, the default password is blank so just hit Submit if you haven't changed the password yet.

2.) in the left column, click on "Wi-Fi Protected Setup." Now, on this page set the "Wi-Fi Protected Setup (WPS") and the "WPS hardware button"  to "Disabled" then hit apply changes, it may ask you to wait 60 seconds or so as it restarts the router. When your router turns back on, make sure it is still connected to the internet before you proceed further. It will tell you if it is or not in the top right hand corner of the setup page.

3.) now, in the left hand column, click on "Channel and SSID." On this page under "2.4ghz," change the "Wireless Channel" to "11," and turn "Protected Mode" off. Still working under "2ghz," change the "SSID" name to something different, anything will do, this is the name of your network as it will appear on all of your devices, remember it, you will need to look for this name on your xbox wireless networks in the wireless configuration menu.  Make sure the "Broadcast SSID" box is checked. Under "5ghz" change wireless mode to "off." Hit Apply Changes and it will ask you to wait while it restarts the router. When your router turns back on, make sure it is still connected to the internet before you proceed further.

4.) left hand column again, click "Security." Under "2ghz" change the "Security Mode" to "64bit WEP." The "Key" will now appear below with five small text boxes. You need to enter two digits in each of these boxes. This will be your log-on password to your router, so remember it. You will need to enter this password the first time you log on to the router with each of your devices. If you had an old password, forget it, this is your new password. Hit Apply Changes. Again your router will ask you to wait as it applies the changes and restarts.  When your router turns back on, make sure it is still connected to the internet before you proceed further.

5.) start up the xbox, go into your system settings, network setting, wireless networks, and then look for the name of your network, it's the new name that you chose in step 3, the SSID name. Select the network and enter the log-on password you chose in step 4. Enter this password without any spaces, it is also case sensitive. Hit enter and your xbox should now connect to your router and the internet.

6.) the first time you log-on to your router from your other devices, you will need to find the new wireless network name from the list of scanned networks, select it and enter the password you chose.

7.) After all of this you should now be able to log-on to your router and internet automatically with all of your devices.

As I was doing this fix I had a couple of concerns, namely in that I turned the 5ghz wireless signal off as well as several secuirty options. However, after having the router setup in the above manor I found my internet performance actually increased and secuirty is pretty tight too. I had my doubts but this definitely worked for me. If this is all too confusing, then just call the Belkin support line, granted they are not the best customer care center but be persistent and call in the afternoon, I called like 5 times at night and no one could seem to help me, but the first time I tried calling during the day the representative solved my problem right away. I know that's all a pain in the @@@ and shouldn't be necessary but learning this now will save time in the future with other products you may come across, plus you already bought it, you may as well learn how to use it.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

also, update your firmware. It's an option on the setup page, left hand column, under firmware.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The only real problem with the unit was the WPS - with that turned off you can run the restore to factory defaults on the console and reboot it, when you do it will easily connect most of the time.

Also the "protected mode" option is a great benefit to your connection, it helps eliminate potential wireless interference to your network, so I'd recommend turning it back on.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for posting that up afterooster. I'm glad its worked for you but I have numerous issues with the advice you've been given by Belkin

 

  1. You shouldn't have to do any of that in the first place it should just work, time and time again there are issues with Belkin and Xbox either with NAT/MTU or them not talking to the Xbox adapters
  2. Your having to turn off 5Ghz and use 2.4Ghz, 5Ghz is a great bonus and should be used if you can as it means less interference, so you've turned off one great feature of the router (depending on the adapter your using on the Xbox you might not be able to use 5Ghz anyway, but other wireless devices could)
  3. You've changed to WEP security the worst possible form of security which ranks just above having none at all, this also means this will not work if you are using the Wireless N external adapter or Wireless N internal adapter as WEP is not part of the N standard

 

If it were me I would have returned the router to store as not fit for purpose and bought a Dlink, Netgear or Billion

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I would have been tempted to just turn leave WPS off and keep your other settings on, so I would have tried WPS=Off, 2.4Ghz & 5Ghz on, WPA2-PSK (AES) security

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Shad0manUK, yeah I know man, I didn't like turning off those settings either, but this was literally the only way to get this belkin router to work, wirelessly, with my xbox. I've since tried other settings(for comparison, the other settings did not work with my xbox), enabled 5ghz, used wpa2-psk, etc and there wasn't any change in performance. So I'd bet that this just isn't a very good router. Like you said, Belkin does not have the best reputation, and this whole process is more than ridiculous. I would've returned it, but I bought it online and returning it wasn't an option (stupid move, i know), so I was determined to get it working. Next time I'm getting a Lynksis or something that is known to function properly. So to anyone else having this problem, maybe think about investing in a more reliable brand.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.