Bad lag all weekend on XBL

I've been trying to play SSFIV today but I have been getting so much lag it's ridiculous. Has anyone else been getting a lot of lag lately?

 

I have forwarded all of my ports and I have a decent connection (18ms ping, 9.8Mbps down, 0.47Mbps up - I just ran a test) and I am using an ethernet cable to connect to my router. On top of that I've even tried bypassing my router altogether by plugging directly into my modem. But nothing works. I'm still getting lag. If I play with someone with a really good connection I can avoid some of the lag but it comes back sporadically. 

 

It's unbearable. Completely ruins the online experience. I played about 10 consecutive ranked matches and it made me want to pull my hair out. Lag in every single one. I even got lag when I played some people on my friends list who I never used to get lag against.

 

Is there anything I can do to avoid this lag (outside of getting a better broadband package)? If I had to guess I would say that it's a problem with the XBL network. Overcapacity or something, maybe because of all the new players coming over from PSN.

 

Question Info


Last updated July 4, 2018 Views 0 Applies to:

Hey man, I've been having the same exact problem. I play Halo: Reach and the past couple of days I've been lagging horribly. I never ever lag and it just recently started happening. I have no idea what's going on either.. I want answers!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I've also been lagging pretty bad lately too and I never lag. I also want answers.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It's still happening. People I used to play against al the time with no lag - all of a sudden it's unplayable. What is going on?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey mate, it appears that your upload speed is a little low for gaming on LIVE. If other posters in this thread have a similar upload speed, I suggest calling your ISP to see if anything's changed on their end, or if there's anything they can do for their connection.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.