Anyone else having party connection issues?

Just today I tried to log in and start a party with a friend I have ALWAYS played online with, and we can't connect to each other's parties, games, etc. Both NAT's are open. We were even playing last night, no problems. Seems like it could be a server-side issue...

 

Question Info


Last updated July 4, 2018 Views 3 Applies to:

UPDATE: My friend is also reporting not receiving my game/party invites, etc. Definitely seeming like an issue on LIVE's end now... :-\

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yup, seems that way.

forums.xbox.com/.../111642.aspx

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

You should get in touch with @XboxSupport on Twitter.  Apparently this isn't occurring with everyone.  They are looking into it for me now.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.