Ambassador MSN User

i was accepted 10 days ago , the ambassador account did not add me so ive added it myself , then ive informed @XboxAmbassador and told him to set the bot to add me to freinds , he sent me a message a day after saying "ive done it , good luck" but now i went to check my freinds list and the ambassador bot isint there , what to do?

 

Question Info


Last updated July 4, 2018 Views 1 Applies to:

i have messaged you on xbox .

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

i have the same problem i did not receive an add either and manually added myself.  It also said spend some time surfing the forum page and you would be added.  It did not open as well.  What to do?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey there Jae!
Send an Email to *** Email address is removed for privacy *** and explain your issue.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.