360 wont connect to my secured wireless network. but will connect if i remove security?

i just switched to cable internet today from DSL and  my xbox 360 wont connect to my wireless internet it says i might have entered the wrong wpa key. i checked and its right and i have other wireless devices working on the network fine.  so i removed the security on my wireless modem it connects and it works fine but i dont want other people "stealing" my internet lol. i tried rebooting/resetting the modem and changing the password and still no go.  the cable modem is an SMC model SMC8014wn   any help would be appreciated. thanks

 

Question Info


Last updated July 4, 2018 Views 1 Applies to:

portforward.com/.../Xbox_Live_360.htm

This will help you when you get connected

But there might be something with the wpa types i use wpa2-personal and it is working find under AES encryption.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.