360 HDMI has magenta hue + audio is garbled (only on one av receiver)

I just received a new Denon avr-x2000 receiver. When my 360 is connected I can see the video but it has a magenta hue and the audio is severely garbled (choppy, white-noise-like audio that kinda sounds like what it should). Before I send back the Denon I checked my Xbox one and my hdmi camera ... they both work as expected. Additionally the 360 worked well with my previous Denon (different, older model). If I plug the 360 into my Samsung plasma directly all is well. Also if I plug the 360 into the Xbox one which passes through to the new Denon then it works fine. So it is not clear if the problem is with the 360 or the Denon. But clearly there is a problem. I have tried 4 different hdmi cables. I have tried the boot with Y+RT graphic reset thing. I have tried changing the 360's resolution, color space, monitor detection, etc. nothing has been successful. This is my FOURTH 360. I have a stack of 3 other non functional 360s due to graphics failures; all of which are out of warranty (failed JUST out of warranty). My usage model is light game play (as in 5-10 hours a month) plus daily Media Center Extension use (PLEASE bring MCE back to Xbox one). This new problem has done nothing to improve my perception of Microsoft's poor quality. Any advice is appreciated.
 

Question Info


Last updated July 4, 2018 Views 0 Applies to:

Reposting (previous post ate formatting)...

I just received a new Denon avr-x2000 receiver. When my 360 is connected I can see the video but it has a magenta hue and the audio is severely garbled (choppy, white-noise-like audio that kinda sounds like what it should).

Before I send back the Denon I checked my Xbox one and my hdmi camera ... they both work as expected. Additionally the 360 worked well with my previous Denon (different, older model).

  • If I plug the 360 into my Samsung plasma directly all is well.
  • Also if I plug the 360 into the Xbox one which passes through to the new Denon then it works fine.
  • I have tried 4 different hdmi cables.
  • I have tried the boot with Y+RT graphic reset thing.
  • I have tried changing the 360's resolution, color space, monitor detection, etc.

So it is not clear if the problem is with the 360 or the Denon. But clearly there is a problem. This is my FOURTH 360. I have a stack of 3 other non functional 360s due to graphics failures; all of which are out of warranty (failed JUST out of warranty).

My usage model is light game play (as in 5-10 hours a month) plus daily Media Center Extension use (PLEASE bring MCE back to Xbox one). This new problem has done nothing to improve my perception of Microsoft's poor quality. Any advice is appreciated.

 

I am slother

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.