2-3 / 4 bars - but still disconnects and won't load updates

My TV and Xbox is in my basement and the router 2 floors above me. I surf fine on the WiFi with my laptop and smartphone down here, but the Xbox won't connect. It claims to have 2-3 bars out of 4 most of the time, and sometimes it works for just a moment, but then it suddenly disconnects or won't load an update.

I tried to download an update for CoD: MW2 and got an error code: 3cd6 0000 d080 0200 8007 2af9

I have no idea what to do. Is it my WiFi signal or something else? The "Test Connection" says it's fine, from Xbox to Wifi to Internet to XBOX Live, though it takes a while for it to establish.

Any help will be appreciated.

 

Question Info


Last updated July 4, 2018 Views 1 Applies to:

Glad to hear you were able to get this resolved, GreyMist93. Happy gaming to you! :)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Seems like the problem was between Internet and Xbox Live, not between the Xbox and WiFi. Restarted the router, seems to work now. Thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hello GreyMist,

The stated error code shows a problem connecting to the Live servers, please can you make sure that UPNP and have you tried taking the xbox upstairs to test it through ethernet?

Thanks,

Dan.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.