Unable to block emails from a specific sender

Original thread title: Not able to block emails from a specifiec sender

Hey guys

I'm trying to block all the emails which come from @yahoogroups.com, but i can't do that. When i try to add this domain name to blocked list, the server responds that i can't add this domain name to block list, while i have done the same thing with other domains and it works!

Any idea?
 

Question Info


Last updated January 3, 2019 Views 429 Applies to:
Hi,

We're sorry for the inconvenience this has caused you. Let me see if I got you correctly. You were unable to add e-mails to your blocked senders as you're getting a server response saying that you cannot add the domains to blocked list while other domains work fine. Am I correct?

I suggest that you try to clear your browser's cache. This is to make sure that the temporary internet files are not contributing to the issue. If you're using Internet Explorer, click here for the steps.  If you're using a browser other than Internet Explorer, you can refer to the browser's help section or you can refer to this link and follow the steps appropriately for your type of browser. Let us know the result.

If this doesn't work, try it on a different browser. This is to eliminate the possibility that the browser itself is causing the problem.

Should you have further questions, don't hesitate to post back.

Thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi

I tried clearing browser's cache but it didn't help (Firefox). I tried using Icognito & Private Browsing Mode and it didn't help. I tried IE, Firefox & Chrome, didn't help.

It's just the (@yahoogroups.com) domain which can't be added to blocked senders, all the other domains i have tried worked.

Thanks for your respond

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi,

 

I see that you cannot add a certain domain in your blocked senders list. Let me assist you on this.

 

Please be aware that it is by design you cannot add domain of a major email service provider. As a workaround, you may create rules that will automatically delete messages from email addresses containing the said domain. Here’s how:

  1. Sign in to your account.
  2. In the upper-right corner of the page, click wheel/cog icon, and then click More mail settings.
  3. Under Customizing Outlook, click Rules for sorting new messages.
  4. Click New.
  5. Select an option how to determine messages you want to be deleted. For this case, select “Sender’s address contains”, then type the domain you wish to be blocked.
  6. Tick Delete these messages—don't even put them in my Deleted folder.
  7. Click Save.

I hope this helps. Should you have further questions, feel free to reply to this thread.

 

Thank you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi

Well, it's not a direct solution but still a good alternative solution.

Thanks

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.