Why do I see strange characters in mail messages?

Technical Level : Intermediate

Summary

You may sometimes see strange characters or character combinations instead of punctuation marks in messages. Typically, these are three-character groups like ’, or sometimes  or ¿. This article explains how the encoding settings in Windows Live Mail 2011/2012 cause this to happen and how to avoid it.

Keywords: "weird characters", "odd characters", gibberish, apostrophe, quotation, quote


Details

About character encoding

All email messages have to be converted to a stream of ASCII text characters for transmission. If a message contains characters that aren’t in the ASCII character set, email programs and services use various ways of converting those characters to combinations of ASCII characters for transmission. This process is called character encoding, and both the sending and receiving computer have to use the same technique if recipients are to see what the sender intended them to. This doesn’t always happen.

Messages you have received

When displaying a received message, Windows Live Mail will use the encoding specified at Options > Read > International settings if Use default encoding for all incoming messages is selected. Otherwise, it will use the encoding specified in the message headers, or if none is given, its best guess at an encoding based on the content of the message. 
 

  • If you see strange characters in a received message, click the Encoding button on the ribbon and select a different one, like Unicode (UTF-8). If this makes the text display properly, you may find it best to leave Use default encoding for all incoming messages not selected.
     
  • If the wrongly-displayed text doesn’t change, it may have been hard-coded into the message by the sender, for example by forwarding or replying to a message wrongly displayed at his end. You can’t do anything about this other than draw the sender’s attention to the fault.


Messages you have composed and sent

Windows Live Mail 2011/2012 converts "straight" quotes and apostrophes in HTML messages to “curly” ones.
This will with some settings involve using Unicode characters, so the message will be transmitted using Unicode (UTF-8) encoding regardless of the setting at Options > Send > International settings. If recipients then read the message using a different encoding – like Western European – they will not see the characters you intended them to.

Sadly, there is no command in the program’s user interface to change this behaviour. If you see it happening, you can reverse the change by pressing Backspace, by clicking Undo  on the Quick Access Toolbar, or by pressing Ctrl-Z.


To stop the behaviour altogether requires a change in the Windows Registry.

With Windows Live Mail closed, type regedit into the start search box and press Enter. Give UAC permission if asked.
 

  1. In the left-hand pane, navigate to
    HKEY_CURRENT_USER\Software\Microsoft\ Windows Live Mail\Compose\Preferences\PostEditor\Autoreplace
    and click on Autoreplace.
     
  2. In the right-hand pane, double-click on SmartQuotes. Type 0 (figure zero) into the Value data box and click OK.
     
  3. Press F5 and then close the Registry Editor window.
     
  4. Launch Windows Live Mail and test.

         Kudos to Peter.R, who first identified the undocumented registry key involved. 


See also

Wikipedia article on ASCII 

Where are the program options?

Wikipedia article on Unicode

 

Forum Article Info


Last updated May 21, 2019 Views 50,156 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

I tried all the suggestions I could find to get rid of these strange type in my Live Mail print.  Nothing helped!

Walter

Climbimg the highest mountain starts at the bottom

so have I over several months. I always use yahoo for my email. You try living in a mainland European foreign country when you are  English, have a brain injury after brain haemorrhage and still trying to sort out so much on Windows 8.1 - I find it difficult to follow technical instructions - there are too many at once to remember and then activate. I bought my computer in UK 3 wks before I ended up in hosp in diff country where I live.  My physical location (computer) doesn't help when doing so much in English but needing local websites and email - where many recipients use locally bought computers.

Changing language on computer doesn't always solve problems for me - but all this started 2 years ago for me and I have commented many times to MS and other major software developers, who mainly fortunately are US or possibly UK based.

MSN has a problem here and their responses are BS. I only have this problem when using mail within my MSN browser.

It's been going on for the last several months with my emails. Any emails I receive in Unicode (UTF-8), I get this,  â€™.  This obviously has been going on since about 2012, after researching this and other posts, yet it appears there is no resolve for it.

I believe as some others do, that it happened after an update as I have never had the problem before. I never changed any fonts to receive or send emails or anything with it's encoding.

I don't have the problem with Outlook (which is terrible, I won't even use it, difficult to naviagte) and I don't have the problem using Google mail or Yahoo.

I really wish they would get this fixed as it's very annoying.

I see your post was on December 9, 2014.  Today is February 4, 2016 and this issue is STILL a problem!!!!!  I'm so sick of it!!!!  In what world is printing out something that ends up looking like partial gibberish ok???????

Yes, and not only that, but it appears to be getting worse. MS is always ready with this update and that update, but they refuse to develop a fix for this. All they give are some BS excuses as to why it happens and any fix they give doesn't work. What that mean is, they don't know how to fix it

I've had an MSN premium membership for well over 10 years. If they don't get this fixed soon, I'm gone.

I'm sure we're not the only ones with this problem. Many are probably just ignoring the characters. This has to be a much larger problem than they will admit to...and they can't figure out why they are losing members and market share.

Oh, that's right, Windows 8.1 is horrible software and on one newer computer, they keep wanting me to do a free upgrade to Windows 10? Why would I want to do that? Upgrade from something that sort of works to something that probably doesn't work at all?

When this old computer is finished, I am going Apple.  I have had MS right up to my cute little 80 year old ears.  
Simple fix for MSN. possibly everyone else. Go to settings, then click email settings. Check the box that says view messages in plain text. Problem solved!

Check the box that says view messages in plain text. Problem solved!

No, not solved. While this might help for some messages, it won't for all, because it's the encoding that counts. Here is the same message viewed in plain text using the same font but with different encoding settings:

Noel Burgess | Certified Pedant | Claims to know a bit about Windows Live Mail

No, it doesn't fix it, at least didn't for me. It changes the encoding. It does fix the problem with the strange characters for emails in Unicode, but any email with graphics, it converts the graphics to this:

body { font-family: Arial, sans-serif; font-size:12px; font-weight:normal; } .smallfont { font-family:Arial, sans-serif; font-size:10px; color:#666666; } .footnote { font-family:Arial, sans-serif; font-size:12px; color:#666666; } .footerlink { font-

Also, around the text in a Unicode email when displayed in plain text, it displays verticle lines here and there within the email, so it's not a clean conversion. It is probably something a person could live with, but not displaying any graphics within the email when using plain text, won't work for me.

Seems like MSN can have mutiple updates, fixes and whatever, but they won't address this problem and fix it. It's very frustrating.

This problem is when using MSN mail within the MSN browser (with the butterfly logo). It is not a problem with Outlook. Some my say just use Outlook and forget it. I absolutely hate Outlook. I think it is the most horrible email program anyone every came up with. The MSN mail program is within the MSN browser and it should work. This is a paid for subscription and MSN should be obligated to fix the problem.

This problem is when using MSN mail within the MSN browser (with the butterfly logo).

Please look at the Applies to line at the top of this article. MSN Mail and Windows Live Mail are very different applications. If you have a problem with MSN Mail, please refer to the MSN forum for assistance. 

Noel Burgess | Certified Pedant | Claims to know a bit about Windows Live Mail

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.