Q: Windows Store doesn't work on Surface 2 Win 8.1 RT This thread is locked from future replies

I have a serious issue: the Windows Store app doesn't start on my German Surface 2 Win 8.1 RT. It just hangs on the splash screen.

Since it always worked, I'd guess it's caused by the latest Windows updates. Obviously, that guess isn't fallacious:

To resolve, I tried everything discussed in


- without success.

I also followed these instructions:

  • sfc /scannow returns no results
  • The Apps troubleshooter returns no results
  • wsreset.exe launches the store, but it keeps hanging on it's splash screen

Only my Surface 2 Win 8.1 RT is affected, and just since a few days, respectively since the latest Windows updates. Another user account is present on that Surface, for her the Store still works. On all my additional various Win 8.1 x64 PC with latest Windows updates the Store works as it should.

"Refreshing Windows" means worst case, pls beware. Hoping this issue getting resolved with upcoming Windows "Spring update" means helplessness.

Any qualified help would be highly appreciated, thanks in advance!



I have a fix!!!!! (for Windows Store not loading, just spinning with no end in sight)

the Cache needs to be cleared but wsreset does not do this for some reason... 

I saw how making a new account would make the store work, and sometimes one account on a PC would work and another one wont. Thats because the Cache to the store is corrupted. Its a very easy fix, although you will need a little knowhow. 

1. First thing you're going to need to restart your machine so none of the files are in use, when Windows restarts don't open the store!!!

2. search in the charms bar for: Folder Options click it and in the second tab in folder options (view tab) click "show hidden files, folders, and drives"

3. After you can see the hidden files open the file explorer go to your C:\ 

navigate to this folder c:\users\(your name)\AppData\Local\Packages\WinStore_(a bunch of letters)\LocalState\Cache\

4. now I would say delete everything in this folder but just to be safe make a new folder on the desktop and move EVERYTHING there, should be a bunch of numbered folders starting with 0 and a file called cachemetadata.dat MOVE OR DELETE IT ALL!!! now try and open the store again, the store should make fresh files and now open (after a little time wait a few seconds)

it worked for me on BOTH of my machines and I REALLY need to hear back from you guys if this works. If it does work than I/we can contact Microsoft to make a fix that will delete this folders contents and help thousands...

I know just from searching I have found DOZENS of web pages that people are screaming for a fix for this... and me being one guy that it happened on not one, but TWO machines it was something that needed attention... all it took was 2 hours of poking and moving files to find, I have not a clue what Microsoft is doing and why they couldn't have found this... (if it works for you ;)

my name is Dustin I do computer repairs out of my home in Adams MA I love computers, it's my hobby and (trying) to make it my full time job... let me know if I can help you any more!

Dustin Stone

*** Email address is removed for privacy ***

(P.S.) I've been coping and pasting this to all the forms I can with great results)

OK,, so, I navigated as far as to the packages, and then i was supposed to look for the WinStore right? Well it wasn't there! Another thing is a little while ago I was trying to repair my firewall manually because of a common error, where I was supposed to go was supposed to have the firewall there, apparently my computer came without a firewall? Microsoft you have some serious problems you better fix all these errors or I'm going to join tens of thousands of others in moving over to mac -_- YAY TIME TO DO A COMPLETE COMPUTER RESET! (assuming the tech support people really are as incompetent as I have heard from trying to fix my problems on the forums and reading other peoples posts.)

Did this solve your problem?

Sorry this didn't help.

1 person was helped by this reply



I tried everything discussed, without success:

In desperation, I even tried opening Store with both SmartScreen and Windows Defender disabled (while second is a little tricky to achieve) - without success.

Finally I resolved it with resetting Windows ...

You might want to try if refreshing Windows yet is sufficient. Since I already investigated days over days in this issue without success, I had more than enough and skipped that step. Pls let us know about any findings.

Did this solve your problem?

Sorry this didn't help.

Question Info

Views: 2,780 Last updated: January 4, 2018 Applies to: