Windows XP Update doesn't work, How to stop Office 07/10 Updates??

For the past few months, the web version of Windows Update does not work with XP. When you click the button for Express or Custom install, the system stalls out looking for updates. So I had to set Windows to notify me of updates instead of going to the site, but now it keeps wanting me to download updates for Office 2007 and 2010, but I don't own those products (I use Office 2003).  I could not get it to stop this, even when I checked the box not to notify me of those anymore. Finally I went to the site and found an option to Disable Microsoft Update, which said I could still download updates from the site, But I can't because it tries to force me to re-download Microsoft Update.

 

What's going on?  I don't like the new Microsoft Update because it keeps nagging me to download updates for products I don't even own. How can I update only Windows XP??????  This is very fustrating.

 

 

 

 

Question Info


Last updated October 22, 2018 Views 3,779 Applies to:
Answer
Answer

For the past few months, the web version of Windows Update does not work with XP. When you click the button for Express or Custom install, the system stalls out looking for updates. So I had to set Windows to notify me of updates instead of going to the site, but now it keeps wanting me to download updates for Office 2007 and 2010, but I don't own those products (I use Office 2003).  I could not get it to stop this, even when I checked the box not to notify me of those anymore. Finally I went to the site and found an option to Disable Microsoft Update, which said I could still download updates from the site, But I can't because it tries to force me to re-download Microsoft Update.

 

What's going on?  I don't like the new Microsoft Update because it keeps nagging me to download updates for products I don't even own. How can I update only Windows XP??????  This is very fustrating.

 

 

 


Hi Steve,

Please do the following.

Go to Start | Settings | Control Panel and double click Automatic Updates. I'll explain why later.

Next, checkmark the bottom option to disable Automatic Updates and then click Apply/OK.

Next, go to Start, Run, copy/paste this command and click OK: services.msc

In the list of Services, can you see Background Intelligent Transfer Service ?

Here's a pix of what it looks like.




If it's not listed, please proceed as follows to register the BITS service.

Open the Windows Search tool, copy/paste the following and then click Search: qmgr.dll

Search should show that file in the following locations:

C:\WINDOWS\system32
C:\WINDOWS\ServicePackFiles\i386
C:\WINDOWS\system32\bits

You might only see qmgr.dll in C:\WINDOWS\system32 depending on your setup.

Next, go to Start, Run and copy/paste: regsvr32 qmgr.dll and click OK

Do the same with this file: regsvr32 qmgrprxy.dll

Reboot the system and then copy/paste this command into the Run field:
%windir%\System32\rundll32.exe setupapi,InstallHinfSection DefaultInstall 132 %windir%\inf\qmgr.inf

If you're prompted to insert the Windows installation CD, ignore that and in the dialog box at the bottom, change the path to C:\WINDOWS\ServicePackFiles\i386

If you could only see the file in C:\WINDOWS\system32, change the path to that instead.

Restart the PC again and then go to Services and you should be able to see BITS in the list.

Double click it and then on the General tab, click the Start button to try and start the service manually. This is just a test to ensure that it's working correctly.

If you get Error 2: cannot find the file specified, go to Start, then Run again and copy/paste the following command and then click OK:
Reg add HKLM\SYSTEM\CurrentControlSet\Services\BITS\Parameters /v ServiceDll /t REG_EXPAND_SZ /d %windir%\System32\qmgr.dll

Reboot again and then try once more to start BITS. It should work properly now, but in the unlikely event that it fails again, run the following command and then hit Enter:
Reg add HKLM\SYSTEM\CurrentControlSet\Control\BackupRestore\FilesNotToBackup

Reboot once more and then do the following.

Go to this link and install the  IE8 cumulative December update:
http://www.microsoft.com/en-gb/download/details.aspx?id=41404

If you use IE7, use this link instead:
http://www.microsoft.com/en-gb/download/details.aspx?id=41442

Finally, go to the Windows Update site and you should be able to download normally.

Provided that's the case, re-enable Automatic Updates in Control Panel.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.