Windows Firewall problem with Google Chrome

Hello. Earlier today, I opened up Google Chrome and was given one of those Windows Firewall prompts that says "Google Chrome" is attempting to ..... I accidentally hit always block, instead of always accept and now I can't use Chrome. I get this message:

NS lookup failed. DNS is the web service that translates a website's name to its internet address. This error is most often caused by having no connection to the internet or a misconfigured network. It can also be caused by an unresponsive DNS server or a firewall preventing Google Chrome from accessing the network.

I have tried the following and none of them have worked.

1) I added Google Chrome to the list of accepted programs in Windows Firewall.

2) I restored the default settings in the Firewall.

3) I did a system restore to yesterday.

4) I ran my virus software.

5) I cleaned my dns cache.

6) I unchecked the "Use DNS pre-fetching to improve page load performance" in Chrome.

Nothing has worked. I know this has something to do with the fact that I told the Firewall to block whatever Chrome was attempting to do, but I can't seem to unblock it!

Can anyone help????????? 

 

 

 

Question Info


Last updated August 19, 2019 Views 32,079 Applies to:
Answer
Answer

Hi,

 

As the issue is with Google Chrome I would suggest you to post your query in the Google forum for better assistance:

http://www.google.com/support/forum/p/Chrome

21 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.