Error connecting (streaming) to Airport Express from iTunes & Airfoil on Windows XP

I am using Windows XP 2002 SP3 on a Dell Latitude E4300 laptop, connecting to a Linksys WRT54G router providing a WPA2 Personal (TKIP+AES) home network. 

I can see my Airport Express 802.11n in iTunes 10.4.1 and can select it via the Airplay button. But when iTunes tries to connect, it comes back saying "An error occurred while connecting to the Airplay device xxx. An unknown error occurred (error -15000). 

A similar problem happens with Airfoil from Rogue Amoeba that I use to stream music from other apps such as VideoLAN to Airport Express. I can see that my Airport Express is available but when Airfoil tries to connect, it comes back saying that "It appears that a firewall on this computer is preventing Airfoil from connecting to xxx Airport Express. Please check your firewall settings and try again.". 

I've set both Airplay and iTunes as exception programs in my Windows Firewall setting, and even added TCP ports 5000 to 5005 and UDP ports 6000-6005 to the exceptions as recommended by Airfoil. I've also disabled Symantec Endpoint Protection that I have installed. The only thing I can't disable is McAfee Endpoint Encryption, since I also use the laptop at work and I don't have permission to disable McAfee. 

How do I trace what is going on that is preventing iTunes and Airfoil from streaming to the Airport Express?

I also have a Windows Vista running on another Dell Inspiron laptop on the same network, and have no problems streaming music from iTunes or Airfoil to the Airport Express on the same network.

Thanks
 
Question Info

Last updated March 30, 2018 Views 3,023 Applies to:
Answer

Hi,

 

The error message you are receiving is related to the firewall blocking the connection on the Windows XP as you can connect using Windows vista computer.

You will need to disable Mcafee on the computer for which you may contact system administrator at work to enable access to Mcafee and check if it helps.

Did this solve your problem?

Sorry this didn't help.