Xp hangs at mup.sys on startup

MY DESKTOP HANGS AT MUP.SYS ON STARTUP.  ANY IDEAS ON WHAT'S CAUSING IT?
 

Question Info


Last updated December 8, 2018 Views 123,700 Applies to:
Answer
I Think what AreilMT is getting at with the HDD light flashing is this:

If you have a chkdsk scheduled to run on the next reboot (by responding in the affirmative to the question when choosing to run a chkdsk on the next reboot), or if XP finds that any volume on your system that has been marked "dirty", chkdsk is going to run when you reboot.

If you boot in Safe Mode and chkdsk starts to run, the last thing you will see on the screen is mup.sys having been loaded...  then the chkdsk is going to run to completion.  Your system will appear to be stuck.

If the system appears to be hung on mup.sys and the HDD light is flashing, it could be that chkdsk is doing what it is supposed to do or what you told it to do - checking the volume(s) for consistency.  If that is the case and the HDD light is flashing, you need to wait it out and that could take many/several hours depending on the size of your HDD, how much stuff is on it and what chkdsk finds to do.  Let it sit overnight if you have to, but be patient.

If that is NOT the case, then I suggest you power off, unplug everything except the keyboard and see if you can boot in Safe Mode with only a keyboard attached.  If you have a PS/2 keyboard to use, I would use that instead of a USB keyboard.  Sometimes a faulty USB device or driver can cause the system to appear to hang on mup.sys.

It is also important to realize that the problem is not with mup.sys (it has already loaded) - it is what comes after mup.sys that could be the problem (if it is not running chkdsk).

This is why it makes zero sense when people see this scenario and start trying to figure out how to replace mup.sys - that is not the problem since it has already loaded. 

The next thing to load that sometimes causes problems is often keyboard and mouse drivers - especially USB keyboards and mouses (mice) devices, hence, you should unplug everything - especially USB devices.  You only need a keyboard connected to press F8 to get to the Advanced Boot Options menu and choose Safe Mode and a PS/2 keyboard should be used if you can get your hands on one.

158 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.