Can't enable automatic updates in Windows Security Center

XP Service Pack 3 user.  All of a sudden, automatic updates will not enable in Win. Security Center.  My computer did have a bug last week and I had to run a fix which worked on some of the registry files.  Since then, I cannot enable the updates.  Any clues?  I run AVG, spybot and malware bytes.

********

AutoFix you suggested did not work--nothing happened.  I have SP3, not SP2.  When following your instructions and finding the SP files and i386 folder, I get a prompt stating "the wuapi.dll on winxp sp3 CD is needed.  Is there any way to get the registry files I need or do I need to completely reinstall Win XP?

 
Question Info

Last updated August 11, 2018 Views 12,075 Applies to:

Hi,

 

· Do you receive any error message or error code when you try to turn on automatic update?

 

You may follow the steps from the below link: You cannot turn on the Automatic Updates feature on a Windows XP Service Pack 2-based computer: http://support.microsoft.com/kb/916261

 

How to change your Automatic Updates settings by using Windows Security Center: http://support.microsoft.com/kb/875349

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

AutoFix you suggested did not work--nothing happened.  I have SP3, not SP2.  When following your instructions and finding the SP files and i386 folder, I get a prompt stating "the wuapi.dll on winxp sp3 CD is needed.  Is there any way to get the registry files I need or do I need to completely reinstall Win XP?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have exactly the same problem. I run Windows XP Home with SP3 and am unable to turn on Automatic Updates in the Security Centre or via System in the Control Panel.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

You need to set up an incident report with Microsoft and they will walk you though fixing this problem.  It is a problem with your registry files.  It took me 3 weeks to get this fixed, so make sure you are a patient person.  Just keep trying their suggestions and by about the 3rd suggestion, it should fix your problem.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I know this was posted a while ago but when it ask for the wuapi.dll file point to %windir%\system32.  In most cases, this would be "c:\windows\system32".

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same problem. win xp sp3 will not allow me to change settings in windows update in control panel. I have downloaded the fix it tool and tried to fix it. Microsoft said it was fixed but there is an issue with default locations have changed. I have not found the fix yet. I was going to try to overlay but my version in box is sp2. The only way i can think of fixing it is reformat. Any other suggestions would be welcome.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Start your own thread MuddyMan2. You are more likely to get results if you do.
Take time to let us know if the suggestion worked...or not.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.