Win XP error c0000221 kernel32.dll corrupt

Hello,

I have an HP dv9000 with win xp MCE (came pre-installed), and windows will not load.
Chkdsk keeps looping resulting in error c0000221 (Bad Image Checksum) kernel32.dll corrupted.

I have already tried restoring system to last known configuration but the same c0000221 error appears and the system loops after loading xp screen
Already tried booting in safe mode, but the system hangs at mup.sys.

I don't have the XP recovery CD because the OS was pre-installed by HP

Any help?

Hi cricketer_1,



Did you make any software or hardware changes on the computer prior to this issue?


a) You may follow this link and check if it helps.

"STOP: C0000221 unknown hard error" or "STOP: C0000221 STATUS_IMAGE_CHECKSUM_MISMATCH" error message occurs



b) You may also contact the computer manufacturer to check if they can provide you a recovery disc.

http://h10025.www1.hp.com/ewfrf/wc/siteHome?cc=us&lc=en

 

Hope the information helps.
Please post back and let us know.

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

Hi Debleena,

Thanks for your reply.

The HP Support website unfortunately did not have any links in providing my recovery disk.

I did have a recovery partition and restored my PC to the factory settings (Windows XP SP2) using HP PC Recovery (F11).

My C: was dirty and I ran a chkdsk /f /r and it was working okay after the clean.

It was working fine until I was updating Windows. Many of the Microsoft Windows updates failed (wasn't even trying to install SP3 yet) and it told me to restart my computer. After the reboot the Windows XP splash screen loaded and after that the system hangs.

I tried pressing F8 to restore the system to last known good configuration but again the system freezes after the Windows XP splash screen.

I tried rebooting in safe mode, but the system hangs at black screen with Safe Mode in 4 corners with (XP (R) Build 2600.xpsp_sp2_qfe.090206-1236: Service Pack 2) at the top. I am only able to move the cursor, and that's it.

Is there any way I can fix this without the recovery CDs?

Was this reply helpful?

Sorry this didn't help.

Great! Thanks for your feedback.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this reply?

Thanks for your feedback.

 
 

Question Info


Last updated October 25, 2018 Views 936 Applies to: