Windows Media Player 11 wont give any Album Info

I just downloaded Media Player 11 for my Windows XP Service Pack 2 computer. It plays CD's just fine. But it will not recognize any CD I put in. No cover art, no track titles, no anything. I've tried the get Album Info, and it pops up another screen but just stays blank and never retrieves the info. My old Media Player worked just fine. Can someone please help. It's aggrivating not to have any info to the music I'm listening to. I can't rip any music to my MP3 Player while it's like this also. I tried ripping a NEW cd and it's labled "UNKNOWN"
 

Question Info


Last updated September 5, 2019 Views 4,446 Applies to:

Options > Privacy > you should see somthing like "Update music files by retreiving media info from the internet" (or something like that). Make sure its ticked > Apply > OK

Once you've ripped the files, WMP will try and find the artwork off the internet. Its hit and miss as it can't always find the correct CD artwork on the web, sometimes it approximates !

BTW, you can also manually input the tags on to mp3's using an mp3 editor. Google and you'll find free ones.

Cheers,

Jerry

Ohmigod I lost my star :-(((

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Ye Sir. That's already checked. It pops up another screen with a globe in the top left. After a second the globe stops spinning and nothing comes up on the screen. I've ripped several CD's and afterwards it tells me it couldn't find any data and puts them in the unknown category. Can't figure out why my older one worked just fine, but this one will not

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Do you have a software firewall running? Disable that first and try again.

If it still doesn't work, check  Connect to the Internet in WMP's Options  - Player. Also make sure that Work Offline isn't checked in the File menu of either WMP or IE, and clear IE's Temporary Internet Files.


Tim De Baets
http://www.bm-productions.tk
Tim De Baets
http://www.bm-productions.tk

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I checked all that stuff.........It still doesn't work. Is it the player or the website it's trying to access? Should I delete WMP 11 and reload it ? Right now I cant put any music into my mp3 player cause it wont load anything.......Thanks for the help

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Yes, a WMP reinstall is worth trying.

What exactly do you mean with "it won't load anything"? Can you add new songs to the media library?


Tim De Baets
http://www.bm-productions.tk
Tim De Baets
http://www.bm-productions.tk

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It will load music. But it wont pull up any data on the music. Even when I click on find album info, a seperate screen pops up with a globe on it. After a few seconds, the globe stops spinning and the screen is blank. After it loads the music and it rips it, it's marking it unknown. I tried ripping 5 different albums, and they are all marked unknown. And I tried to do a system restore, but it wont do it now. I tried downloading WMP 11 again and re-installing it, but its still doing the same thing......I dont understand why my old one worked just fine, but this one is junk

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Try resetting IE's settings:  Control PanelInternet OptionsAdvancedReset .

If that doesn't help, create a new user account in Control Panel, log in on that account, and check if WMP can't retrieve any album info there either.

I would also suggest to perform a  Clean Boot , and to check if the problem still occurs there.


Tim De Baets
http://www.bm-productions.tk
Tim De Baets
http://www.bm-productions.tk

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.