Question

Q: Windows XP: USB mouse and keyboard stopped working

After one of the Microsoft Windows updates my USB mouse (Logitech) and keyboard (Dell) stopped working. They are working before login screen and working if I boot from Symantec boot disk. But I cannot login at all because I cannot go through the login screen. Been looking ovet the net for a week - tried some suggested solutions (like add another USB PCI, etc.) - nothing working. I can use keyboard in BIOS settings (all USB legacy is enabled). Computer - Dell Dimension E520, XP pro. And I do not have PS/2 ports unfortunately. Not sure it will work if I will add PCI with PS/2 ports...

PLEASE HELP!!!

Answer

A:

Done unplugging all devices - no changes. tried to boot in Safe Mode with Command Prompt -no keyboard or mouse...

Here are some snippets from DELL website, please take your time to read it and apply as required:

Make sure that you are using the correct ports and also read extensively about theI/O-Panel Components on one of the links provided below.

A USB Device Is Not Detected After Reseating on a Dell™ Dimension™ E520
http://support.dell.com/support/topics/global.aspx/support/dsn/en/document?c=us&dl=false&l=en&s=gen&docid=36A71AB797507F2FE040A68F5B280CA4&doclang=en&cs=

A USB Device is Not Detected

When a USB device on a Dimension E520 is reseated into the same USB port, or swapped between USB ports, the USB device may not be detected by the system.

USB Device Does Not Work When Connected to Desktop Computer
   
Journal ID:       10206J5M9F
Wizard ID:      110448
Date Published:      8/14/2003
Last Revised:      8/21/2009

STEP: Ensure That the USB Device Is Attached Directly To the Port
Additional Information

To ensure the device is attached directly to the port, verify that the USB cable runs directly from the peripheral to the USB port, with no intermediate devices in between.

How to Run the Dell™ Diagnostics Utility
http://support.dell.com/support/topics/global.aspx/support/dsn/en/document?journalid=8BC411B5B323C433E040AC0A63E9670A&docid=A9E3A15597A04AFBB02EE16785D39C5C

Removing and Installing Parts
http://support.dell.com/support/edocs/systems/dimE520/en/SM_EN/parts.htm#wp1184332

Try to make sure the I/O-Panel Components fitted firmly

Extended Test  Dell Diagnostics Main Menu
http://support.dell.com/support/edocs/systems/dimE520/en/SM_EN/adtshoot.htm#wp1059431

On the same page locate "System Messages " and the "Beep Codes " read what can be done and apply.


USB Controller :Set to On (default) so that USB devices will be detected and supported in the operating system.
http://support.dell.com/support/edocs/systems/dimE520/en/SM_EN/syssetup.htm#wp1055144

On the same Page above Under "Maintenance" see this option I mentioned in one of my earleir post:
Load Defaults :Allows you to reset all options in the setup menu to the factory default.


nass -- http://www.nasstec.co.uk

Did this solve your problem?

Sorry this didn't help.

5 people were helped by this reply



 
Question Info

Views: 61,025 Last updated: March 26, 2018 Applies to: