MDAC 2.81 Install/Repair Issue

Am attempting to repair MDAC on a Windows XP Pro SP3 machine.  Reason:  an application using MDAC does not work properly but it does on another WinXP Pro SP3 machine.  Have downloaded MDAC 2.8 SP1 from the Microsoft download site.  Upon launching, however, I receive an error message:  Fatal Setup; This setup does not support installing on the operating system.  This is certainly a strange error message.  MDAC Component Checker and the registry key both show MDAC at 2.81 but MDAC is not working properly.  Please advise where I go next to get MDAC on this machine working properly.  Thanks.

Happy New Year!

 

 

Question Info


Last updated May 16, 2018 Views 6,578 Applies to:

Hello SWAPSysadmin,

You are getting the fatal error because this setup does not support installing on the operating system. (MDAC) 2.8 SP1 System Requirements do not support Windows XP.

MDAC) 2.8 SP1 System Requirements do not support Windows XP.

Supported Operating Systems: Windows 2000, Windows 98, Windows ME, Windows NT.

Note: The MDAC 2.8 SP1 stand-alone release is not supported on the Microsoft Windows XP operating system or on the Microsoft Windows Server 2003 operating system.

To update the MDAC version that is installed together with Windows XP or with Windows Server 2003, you must use operating system service packs or Windows Update.

I suggest that you install an update for MDAC for Windows XP SP3. You can follow the below link to download and install the update:

http://www.microsoft.com/downloads/en/details.aspx?FamilyID=c8efa6e3-d1a5-4222-865b-421a0df2be26

Thanks,
Irfan H, Microsoft Answers Support Engineer. Visit our
Microsoft Answers Feedback Forum and let us know what you think.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you for your reply, Irfan.  I ran the update you pointed me to.  It completed without error.  However, the application using MDAC still does not work.  I then ran Component Checker again.  It states I have MDAC 2.8 SP1 on Windows XP SP3.  I went further into the Component Checker results and discovered there are two file mismatches (no other mismatches reported):

MSADCE.DLL  Expected version is 2.81.1132.0     Found version is 2.81.3002.0

msxlml3.dll     Expected version is 8.90.1101.0     Found version is 8.100.1052.0

Why did the update not correct these two files?

If I were to find the correct versions on another Windows XP SP3 machine, should I just copy them to the machine with the issue?  Would this then make MDAC work properly?

Thanks and Happy New Year!

Further to above:  I checked the two files on the other computer that does run the "MDAC" application properly.  The two files are the versions as those installed on the computer that does not run the "MDAC" application properly.  Please advise what else I can do to repair the errant MDAC installation.  Thank you.

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Help anyone?

 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.