Error: there is no script engine for file extension ".vbs" at Windows XP startup.

Original Title: there is no script engine for file extension ".vbs"

When I log on, I get this box titled "Windows Script Host" that includes a red "x" and the statement:  there is no script engine for file extension ".vbs".  I was haveing problems with my .exe extensions changing, but that was fixed, but this remains.

 

Question Info


Last updated August 15, 2019 Views 49,826 Applies to:
Answer
Answer
Another solution might be to reassociate the vbs files with the following command:
  • assoc .vbs=VBSFile

106 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Answer
Answer

Hi,



Have you made any changes on your computer prior to this issue?


“wscript.exe” is Windows Script Host which is a default program to open “.vbs” file types.


Let’s follow these methods & check if the issue persists:


Method 1

a. Type ‘cmd’ in Start, Run box. Right click on cmd in the Program list and then select the option Run as Administrator.

b. Type the following command, and then press ENTER on the keyboard:

cscript.exe //H:WScript


Method 2


You may re-register the
vbscript.dll file:

a. Type ‘cmd’ in the Start, Run box, right-click on Command Prompt, click on Run as Administrator. 

b. Type ‘Regsvr32 <space> vbscript.dll’.

c. Click the OK button.


Hope the information helps.

63 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.