Windows XP cannot see internet only can see local network

We have a little network in my house. My router was set to WEP security (I know its too old, but my windows xp laptop didn't work with WPA or newer). And I also added mac address filtering for extra security. This network worked fine for like 2 years.

Meanwhile in one laptop (the one has windows XP sp3) so its wireless network broke, and we couldn't get it alive, so we just connected it to the router via cable.

Recently I had to reset my router because I forgot a password and I couldn't add anything to mac filter list.

After that I set everything to the "original" such as WEP + mac filtering (only the passwords were changed).

Now everything works fine, 2 laptops (both has Windows 7), 2 network drives, all our smart phones etc. can connect again, the only one laptop (with Windows XP) has problem.

The XP laptop can see local network (the two drives) and router only (ping works) but in any browser (chrome, iexplorer, firefox) gives me a website cannot loaded in the bottom: Error 105, Err_name_not_resolved.

I tried to ping names (google.com) and different ip addresses (for example my ISP's dns server address) but i get no answer  100% packet loss. I tried a lot of things they didn't help
1) tried change my XP to some fix ip + fix dns (I found those adressis  in my router's setup/network configuration)
2) then i set back to dynamic ip again, in cmd line ipconfig /release, ipconfig /reset, etc, i checked everything the adresses looked fine everywhere (I mean gateway, DHCP server, dns server looked fine with dynamic ip too)

3) then I've found similar post
 http://answers.microsoft.com/en-us/windows/forum/windows_xp-networking/cannot-ping-outside-my-local-network/de73a1f9-ef4b-e011-8dfc-68b599b31bf5 
so I also tried what's in the post
"netsh winsock reset" "netsh int ip reset" then "ipconfig /flushdns" then restart computer

Didn't help so I registered here, maybe i get answer.

you might need these information:
the laptop has _german_ language Windows XP service pack 3
router is Cisco  EPC2425
The two network drives wdstorage + mybookworld... I think they're both western digital stuff. Im not sure, I can look after if its important (I don't think so)
So I got the two drives always connected. (so 3 UTP connection in the router is used, two for drives one for the windows XP laptop)


If something is not clear, ask me please

Thank you for your answer
Robert
Answer
Answer

Hi Robert,


 

Thank you for updating us the case status.


 

I would suggest you to disable the Firewall temporarily.

 


I would recommend you to Test the name resolution



A DNS server provides host name resolution. If you cannot connect to a server on the Internet by using its FQDN, there might be an issue with the DNS configuration of your dial-up connection to your ISP or with your ISP's DNS server.


To determine whether there is an issue with the DNS configuration of your dial-up connection to your ISP, follow these steps:


a.    
At a command prompt, type ipconfig /all, and then press ENTER to display the IP address of your DNS server. If the IP address for your DNS server does not appear, contact your ISP to obtain the IP address for your DNS server.


b.    
To verify that your computer can communicate with your DNS server, ping your DNS server's IP address. The reply looks something like this:


Pinging ###.###.###.### with 32 bytes of data:
    

Reply from ###.###.###.###: bytes=32 time=77ms TTL=28
Reply from ###.###.###.###: bytes=32 time=80ms TTL=28
Reply from ###.###.###.###: bytes=32 time=78ms TTL=28
Reply from ###.###.###.###: bytes=32 time=79ms TTL=28



The series of number signs (###.###.###.###) represents the IP address of the DNS server.


If you cannot successfully ping the IP address of the DNS server, contact your ISP to verify that you are using the correct IP address and that the DNS server is working correctly.
 
When you have verified the correct IP address for your DNS server, update the TCP/IP settings for your dial-up connection to your ISP. To change or add a valid IP address for your DNS server for a Dial-Up Networking phonebook entry, follow these steps:

a.     In Control Panel, double-click Network Connections.

b.     Right-click your Internet connection, click Properties, and then click the Networking tab.

c.     Click the Internet Protocol adapter, and then click Properties.

d.     Click Use the following DNS server addresses, and then type the correct IP address in the Preferred DNS Server box.

e.     Click OK, and then click OK again.

 

 

 

If you need any other information about Windows, feel free to post your questions and we will be glad to help.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

 
 

Question Info


Last updated July 24, 2020 Views 2,654 Applies to: