static ip dns servers blank

I have an XP SP3 workstation to which I need to assign a static IP address.  Our network has a domain with 2 DNS servers.   I entered in the necessary info for IP address, subnet mask, default gateway and DNS on the XP machine, then rebooted.  After this, I have no internet access and get Event error 1053 and 15 in the application log.  I checked the TCP properties and the DNS fields are empty (I am positive I set them correctly and have retried this a dozen times).  If I set the NIC back to DHCP it works fine and no errors are generated.  I've tried resetting TCP using "netsh int ip reset c:\resetlog.txt" but still get the same error.  This is a fresh install so I know there is no virus or malware causing the issue.  I was going to try replacing the NIC but the system is a small form factor box so I would have to buy one and wanted to make sure that would fix the issue before spending the $. 
 

Question Info


Last updated March 4, 2019 Views 1,226 Applies to:
Answer
Answer
Tried that too...no dice...I have found the cause and resolved the issue.  Our network is running Symantec Endpoint Protection for antivirus/malware protection.  There is a feature in version 12.1 called Sonar which protects against network intrusions.  The policy on the affected workstation was set to block DNS changes...hence the blank DNS settings when I tried to manually set them.  I changed the policy to allow DNS changes, entered the IP Subnet Gateway and DNS, rebooted, and...It is working now!  Thank you Cameron O and LemP for your assistance. 

1 person was helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.