Can't Access Workgroup on some computers running XP - "<Workgroup Name> is not accessible. You might not have permission to use this network resource."

I have a home network with four PCs - one of them is running Windows 7 Home Premium (with Homegroup disabled) and the others running XP Pro.  One of the XP machines is called "Server" and has the Server and Computer browser services running and set to Automatic.  The other two computers, called "Laptop" and "Dell", as well as the Windows 7 machine do not have File and Printer Sharing enabled and specifically have the Server service disabled.

 

My problem is that one of the two XP client machines cannot access the workgroup.  Let me be clear about this:  I open Windows Explorer and click on "My Network Places"->"Entire Network"->"Microsoft Windows Network" there is then a 5-10 second pause and then the name of my workgroup appears.  When I click on the workgroup name there is another ~10 second pause and then I get an error message which says "<Workgroup Name> is not accessible.  You might not have permission to use this network resource.  Contact the administrator of this server to find out if you have permissions.  A device attached to this system is not functioning.", where <Workgropu Name> is the name of my workgroup  Other days, after some of the computers are rebooted, I find that this XP client has absolutely no trouble with this; but the other one now has this same problem.  In other words, the problem switches between the two XP clients.

 

Let's analyze:  I have Windows Firewall on all PCs and no other firewall programs.  I have tried disabling Windows Firewall and my anti-virus program (temporarily, of corse) with no effect.  This cannot be an issue with how I have set up my shares because the error happens when I try to click the Workgroup rather than a shared resource.  This cannot be a problem with a specific XP client because at different times, each of the two PCs have worked perfectly with no configuration changes done in between.  It could be a problem with the Server parameters; but I don't see what it could be.  I have tried editing

HKLM\System\CurrentControlSet\Services\LanmanServer\Parameters and changing

IRPStackSize from 21 to 45 and then to 50.  I have also tried changing Size from 2 to 3.  I have re-booted the Server and the XP client and there's been no effect.

 

I do not have the same User Account set up on all three machines.  However, this can't be the issue because the problem happens when I click on the Workgroup, before the Server name is even displayed.  Furthermore, each of these two XP clients have successfully connected with their existing User Accounts at times.

 

I have tried running the Network Setup Wizzard on all four machines, with no effect.  I've tried many other things, most of which I don't remember any more.  I am at my wits' end.  Please help.

 

Question Info


Last updated October 5, 2019 Views 29,759 Applies to:
Answer
Answer

JW,

 

Thanks for the continued help.

 

Per the IPCONFIG advice, I looked at the registry for all computers and found that EnableProxy wasn't there.  According to the documentation it defaults to 0, which is what we'd want.  However, I added it to all computers and left it set at 0 and restarted the computers.  The Node Type still says "Unknown".

 

Thanks for the info on the Master Browser.

 

The ""Network Location Cannot be Reached" when accessing shares"
article is about Windows 2003 Server and none of the symptoms mentioned pertain to this situation.

 

The "Advanced network adapter troubleshooting for Windows workstations" is about hardware troubleshooting.  I think this is unlikely to be an issue because the computer has no trouble accessing the internet, which wouldn't be possible if the network adapter weren't working.

 

I have gone through the automatic fix to reset the TCP/IP stack even though the article describes symptoms as having trouble accessing the internet...  And...  IT WORKS!

 

After re-booting, the PC that was having trouble can now access the workgroup.  All the other PCs still can too (haven't tried restarting everybody again).  BRILLIANT!  I can't thank you enough!

 

I will re-post if the syptoms re-occur; but for now, we can consider this problem SOLVED.

 

Thanks a million,

Adam

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.