Very slow file access

I run Win XP Pro (SP3) on a Dell Inspiron 530.  Auto Updates on, so should be up to date with all patches.

Recently I noticed a problem where any "initial" file access is extraordinarily slow in many different applications. For example Adobe Photoshop CS5 and Thunderbird - but basically everything.

For example when I open a file off my C drive, it sometimes sits there for 30 seconds or more thinking about it before it does anything - even tiny files of 20 or 30 Kb. It does not seem to be any particular file type.  This happens with images, PDF Files, Word Docx files - anything.

It is also slow when I save a file, or attach it to an email.

Sometimes though, if I open (or save, or attach) a subsequent file from the same location (directory) it is quick.  

I don't know if it is related, but it also takes a long time to see thumbnails WITHIN DIALOGUE BOXES - so may also be related to the same problem.

I have looked around in all the forums but could see no answers.  I have deleted ALL my mapped network drives, jus in case that was the problem.

I have run latest Spybot, SuperAntiSpyware, Nod32 and Advanced System Care and none report any malware.  I would really appreciate some help.

Many thanks,
Steve
 

Question Info


Last updated November 12, 2018 Views 1,958 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Hi Steve,

- Have you made any changes to your computer prior to the issue?

Test the issue in a clean boot state.

Note: Follow steps from the article to restart your computer as usual.

Also note: You may not be able to access third party applications such as Adobe Photoshop CS5 and Thunderbird when the computer is in a clean boot state.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I can't remember when the problem started.  A few weeks ago I had to physically move the PC so I set up a wireless dongle to access my home network.  It is now back to being attached via ethernet.  I can't rule out other changes, but that is the only one that comes to mind.

I tried a clean boot. The "Guided" version wouldn't download so I made the changes as described using MSConfig.  It did give me a message saying some of the changes couldn't be completed as I am not an Administrator (I am), but it seemed to do it anyway.

PS5 and TBird started as normal, but the slow file access was the same. Not sure where that leaves me (except very frustrated!)

Thanks for the help. Any other ideas?

Steve

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hi Steve,

- Do you have enough space on the disk?
- Is your computer low on memory?

Follow these steps and check if the issue persists.

Step 1:

Switch the Indexing service off and check if that helps.

a. Click on Start/Run and type "services.msc" and hit OK.
b. Scroll down to find Indexing, double click it, stop it and set it to 'Disabled'.
c. Reboot and it should work faster again.

Note: Start the services after the test.

Step 2:

I'd recommend you check your Hard Disk Drive for any errors.

http://support.microsoft.com/kb/315265

Chkdsk disclaimer.
Important:
While performing chkdsk on the hard drive if any bad sectors are found on the hard drive when chkdsk tries to repair that sector if any data available on that might be lost

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks again for your suggestions. 

Disk space is not an issue. I am using 100GB of a 500GB drive, and defrag regularly.

I had already turned off indexing, without any noticeable improvement.

I have run Chkdsk and it did find errors, so I ran it again with the option to fix.  I ran it again the following day and it did not report any problems. However, I am not so sure that the disk is completely "fixed". (I understand that chkdsk doesn't really fix the disk, just hides them).

When I run programs like Advanced Systems Care, it no longer reports a disk error, but  (a free version) of Iolo System Checkup still seems to recognise a disk error.  

However, my PC has two physical drives, and when I access files from the D Drive, I get exactly the same problem. PS5 just took 15 seconds to open a 5 KB (not 5 MB) gif file.  Previously, that would have been almost instantaneous.

Thanks again for your help. 

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

You might want to check that your hard drive's access mode didn't change from DMA to PIO:

http://www.technize.com/2007/08/02/is-your-hard-disk-cddvd-drives-too-slow-while-copying/

and

http://winhlp.com/node/10

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I had a look at these articles, and ended up  bit confused.  I have two primary IDE Channels. In the first, Device 0 is set to DMA if Available / Ultra DMA Mode 5.
The second is set to DMA if Available / PIO mode. However, it does not offer any current transfer mode other than PIO. I tried everything in the first article, but could not change it.

I also have two secondary IDE Channels. The first is OK, and the second has the Current Transfer Mode as Not Applicable.

I have read through the second article you sent, and will try to read through it again and make some sense of it.  (I'm not sure how the solutions apply if you have 2 primary IDE Channels).

I'll let you know how I go (assuming I don't do any irreparable damage to the PC in the process!)


Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I went through the second article also, and ran the vbs script.  It did manage to change things so now both primary IDEs are using Ultra DMA Mode 5, as is  the first of the two secondary IDE's.

The second Secondary IDE Channel still  has the Current Transfer Mode as Not Applicable.

Unfortunately, after rebooting, I found the delay was still bad.  Opening a 10K image in Photoshop took over 30 seconds, and opening a small 14 Kb Doc file in Word (2010) took about 20 seconds.

:-(

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

After rebooting, you should check the transfer mode to see what it is (just to make sure).

If you look at this link:


Step 4 is interesting:

If the problem is still not solved, set the offending channel to PIO manually, reboot your computer, set the channel back to DMA, and reboot again.

Did you do that by any chance?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I tried opening a file with Windows task manager open.  Here is something unexpected.  When I opened the "open file" dialogue box, the memory usage doubled and CPU usage for Winword shot up to 40-50% even before I clicked on a file name.  I waited until the CPU and memory stabilised, and then selected a file and it opened immediately.

Si I tried the same with Photoshop, but a slightly different result.  Just opening the "open" dialogue box and clicking on a new directory, took the CPU usage for PS to 50% and memory jumped from 119mb to 220 mb for  good 30-40 seconds before I even clicked on a file.  However, it still took another 20 seconds to open the file once selected (during which time the CPU / memory usage shot up again).

Would these programs use a common file handler to brows / open / save etc?  Is it possible that something is wrong here?

Steve

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Did you ever install the optional update KB940157, Windows Search 4.0?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.