Question

Q: Can't delete, view properties, rename mp3 file which has a long filename. I'm frustrated to solve it.

I downloaded a mp3 song but I can't play it either delete it . When I right clicked it, 'copy, cut, create shortcut, rename, delete, properties' options are not shown on the context menu. It has a long filename but I couldnt rename it. I highlighted the file and clicked the 'file' option on the top left of the window...it did show those missing options but they gave no respond when I clicked on them. Then, i downloaded a 'shredder utility' and used it on the mp3 file....When I click delete, it begun to delete those files and folders in the recycle bin, So, I found out that the mp3 is like the 'shortcut' which lead to the recycle bin...It annoyed me for a long time and I hope any experts here can solve my problem....Any way the I can upload picture so that you can understand what I'm actually talking about?


Boot up in safe mode and see if it will delete. If not, give these tools a try also in save mode.

 

FileASSASSIN
http://www.malwarebytes.org/products/fileassassin 

 

Unlocker File Remover
http://www.emptyloop.com/unlocker/

 

Alternate download sites.

Download from FileHippo
http://filehippo.com/download_unlocker/

Download from CNET
http://download.cnet.com/Unlocker/3000-2248_4-10493998.html

===== ===== ===== ===== ===== ===== ===== ===== ===== =====
☞ Avoid a post. Backup your data. ☜

Bruce Hagen
MVP: 2004 ~ 2010
2014 ~ Present
Imperial Beach, CA

Did this solve your problem?

Sorry this didn't help.


I've tried to delete it in safe mode but this method not worked....and Unlocker File Remover also failed to delete it. I was unable to select the mp3 file in fileAssassin because the filename is too long....and it said invalid.

Did this solve your problem?

Sorry this didn't help.


Down load the free program 7Zip and this program will allow to rename the file,

Did this solve your problem?

Sorry this didn't help.

1 person was helped by this reply


Seems like this can happen when the file is in a folder with a really long name (such as an album folder for an album with a long title).

Back up one folder and rename the folder containing the MP3 to a shorter name. Then you should be able to rename the MP3 itself. That worked for me.

Did this solve your problem?

Sorry this didn't help.

2 people were helped by this reply


 
Question Info

Views: 1,641 Last updated: July 6, 2018 Applies to: