Outlook Express Crashes when Clicking on Links in Email Messages

Hi, When I click on a embedded hyperlink in an email message, OE 6 crashes with the following message in the App Events Log: Faulting application msimn.exe, version 6.0.2900.5512, faulting module kernel32.dll.

This appears to have started after I installed several MS security updates. Malware scan showed clean. 

So far I have tried:

- Creating new identity in OE
- Compacting message folders
- Reregister dll's as outlined here: http://support.microsoft.com/kb/2398839
- Confirm that the file association is correct for http hyperlinks: http://www.oehelp.com/ielnk.aspx

What should I look at next?


 

Question Info


Last updated March 26, 2018 Views 2,175 Applies to:

You did everything I would have suggested.  I'm not sure what could be the issue.  Do hyperlinks work okay in IE?  Do you have another browser installed?  Is there antivirus installed?  Antimalware?

 

steve

 

 

 

Steve Cochran, Ph.D.
MS-MVP 1998 - 2014
Outlook Express \ Windows Mail
http://www.oehelp.com

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for the reply. Hyperlinks work OK in IE 7. Google Chrome is also installed. Avast antivirus is installed. Malwarebytes antimalware is installed.

My next idea is to run System File Checker (SFC). If no results, then do a reinstall of OE.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Well, you can't really reinstall OE.  You can right click on the msoe50.inf file in the windows\inf directory, but I don't think it does much.  Go ahead with SFC, but I suspect that Chrome is intefering.  There have been some reports about it not working too well with IE, and consequently your OE experience may be diminished.  I doubt it is Avast, but you can try removing it and see if that makes any difference.  Another thing to try would be to setup a new Windows User and switch to that user and then see if the hyperlinks are screwed up or not.  A defrag sometimes fixes screwy things such as that and you might also run a disk cleanup and wipeout the Temp and TIF files to see if that makes any difference. 

 

Does it crash OE when you click on a link when the message is opened in a separate window, or only when it is clicked in the preview pane? 

 

steve

 

Steve Cochran, Ph.D.
MS-MVP 1998 - 2014
Outlook Express \ Windows Mail
http://www.oehelp.com

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Problem solved. I found that clicking on links in Explorer 7 caused Explorer to crash as well. In further searching I found this KB article: http://support.microsoft.com/kb/928387.

I ended up downloading and installing the latest cumulative security update for Internet Explorer. 

Explorer and OE now work correctly.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I'm glad you were able to resolve it.

 

cheers,

 

steve

 

Steve Cochran, Ph.D.
MS-MVP 1998 - 2014
Outlook Express \ Windows Mail
http://www.oehelp.com

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.