This installation package could not be opened. [SOLVED]

I am trying to install Java 6 update 18 and am getting the error:

"This installation package could not be opened. Contact the application vendor to verify that this is a valid Windows Installer package."

I have uninstalled ad-aware, spybot, and Mcafee.  I have also disabled all vista security and the UAC.  The only account on my computer is administrator.

I followed some suggestions on this site and did a Run and typed in msiexec /unregister, then Run and typed in msiexec /regserver and I still get same error. 

I have also tried running the program as administrator, and with UAC back enabled to no avail.  I tried to download the Windows installer 4.5 for x86 but it tells me that update isn't compatible with my vista installation.  I am running vista home premium 32 bit, so I don't know why I'm getting that error.

I also have service pack 2 installed.

I am completely lost on why this is happening.  This situation with not being able to install Java also applies to a couple of other programs as well, but not all of them.  I can't remember witch ones they are, but Java is my main concern right now and I feel if that gets fixed, the other programs will install as well.

I would greatly apprectiate any help on this.

UPDATE:  I also tried Run and typed in services.msc and found windows installer, and changed it from manual to automatic and started service.
It didn't work either. :-(

--- UPDATE --- UPDATE --- UPDATE --- UPDATE --- UPDATE --- UPDATE --- UPDATE --- UPDATE --- UPDATE --- UPDATE --- UPDATE --- UPDATE ---

This problem is now solved!!!

It seems that the "Run as administrator" command only gives you some administrative privileges, and they're not enough to install Java (and OpenOffice, by association), and other programs as well. In order to get around this, you need to actually log in as administrator. Open a command prompt with admin rights by clicking Start, Run, typing cmd into the search/run box, and hitting CTRL-SHIFT-ENTER. At the prompt, type:

net user administrator /active:yes

Then log out of your regular account and back in as the administrator, where you should be able to install the program. When you're done, log back into your regular account and, for security purposes, disable the administrator account using:

net user administrator /active:no

Wallah, its done and everything works.
 

Question Info


Last updated April 15, 2019 Views 91,719 Applies to:
Answer
Only Microsoft would call that a "solution".


This is a peer-to-peer forum operated by the Microsoft. The proposed solution has come from a member of the public and not Microsoft. The word [SOLVED] in the thread title was entered by the original poster and not Microsoft.

Given that this thread is extremely old, I suggest that if you are having a similar problem you create a new thread for it by going here:

http://answers.microsoft.com/en-us .

I hope this clarifies the situation and helps.   :)

 

 

_______________________________________________________________________
Disclaimer: You use my posts entirely at your own risk. I don't work for Microsoft. I am an unpaid volunteer.

2 people were helped by this reply

·

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.